Bug 177864 - bug-buddy crashes while updating list of products
bug-buddy crashes while updating list of products
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bug-buddy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 177971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 15:52 EST by Ian Burrell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-18 23:25:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 325707 None None None Never

  None (edit)
Description Ian Burrell 2006-01-15 15:52:32 EST
Description of problem:

bug-buddy crashes when updating the list products.

Version-Release number of selected component (if applicable):

bug-buddy-2.12.1-2.1.x86_64

Steps to Reproduce:
1. Run program that crashes
2. Select 'Inform developers'
3. Select 'Update' on update dialog
4. Bug-buddy crashes

It does not crash when "Don't update" is selected.  The following message is
printed on stderr:

Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 &&
percentage <= 1.0' failed
aborting...

The stack trace is:

(gdb) thread apply all bt

Thread 2 (process 3629):
#0  0x00000036ac109436 in ?? () from /lib64/libpthread.so.0
#1  0x0000003a5ee2d3e1 in xfer_callback (info=Variable "info" is not available.
) at gnome-vfs-job.c:1547
#2  0x0000003a5ee43c32 in copy_file (info=0x7b6c40, source_uri=Variable
"source_uri" is not available.
) at gnome-vfs-xfer.c:1285
#3  0x0000003a5ee44586 in copy_items (source_uri_list=Variable "source_uri_list"
is not available.
) at gnome-vfs-xfer.c:1805
#4  0x0000003a5ee45455 in gnome_vfs_xfer_uri_internal (source_uris=0x72d0e0,
target_uris=0x0,
    xfer_options=GNOME_VFS_XFER_DEFAULT, error_mode=GNOME_VFS_XFER_ERROR_MODE_QUERY,
    overwrite_mode=GNOME_VFS_XFER_OVERWRITE_MODE_REPLACE, progress=0x409ffef0)
at gnome-vfs-xfer.c:2546
#5  0x0000003a5ee45cf4 in _gnome_vfs_xfer_private (source_uri_list=Variable
"source_uri_list" is not available.
) at gnome-vfs-xfer.c:2632
#6  0x0000003a5ee2dd31 in _gnome_vfs_job_execute (job=0x710d90) at
gnome-vfs-job.c:1563
#7  0x0000003a5ee2cfc8 in thread_entry_point (data=Variable "data" is not available.
) at gnome-vfs-job-queue.c:68
#8  0x00000036acd40097 in g_thread_pool_thread_proxy (data=Variable "data" is
not available.
) at gthreadpool.c:172
#9  0x00000036acd3e5a0 in g_thread_create_proxy (data=0x7302b0) at gthread.c:582
#10 0x00000036ac10615a in start_thread (arg=Variable "arg" is not available.
) at pthread_create.c:261
#11 0x00000036ab1c92bd in ?? () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (process 3628):
#0  0x00000036ab12f215 in *__GI_raise (sig=Variable "sig" is not available.
) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00000036ab13093e in *__GI_abort () at abort.c:88
#2  0x0000003a5f252706 in ?? ()
#3  0x0000000000000000 in ?? ()
Comment 1 sangu 2006-01-16 12:03:18 EST
See Also : http://bugzilla.gnome.org/show_bug.cgi?id=325707
Comment 2 Ray Strode [halfline] 2006-01-17 20:59:09 EST
*** Bug 177971 has been marked as a duplicate of this bug. ***
Comment 3 Ian Burrell 2006-03-17 02:31:28 EST
This problem seems to be fixed with the current version (bug-buddy-2.14.0-1.x86_64).
Comment 4 Paul F. Johnson 2006-03-18 18:02:13 EST
It's actually been fixed for quite a while, but there is no way to close this bug!
Comment 5 Ray Strode [halfline] 2006-03-18 23:25:30 EST
Thanks, closing...

Note You need to log in before you can comment on or make changes to this bug.