This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 177904 - Pango-ERROR **: file basic-fc.c: line 347 (basic_engine_shape)
Pango-ERROR **: file basic-fc.c: line 347 (basic_engine_shape)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 06:46 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 08:16:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testcase (1.02 KB, text/plain)
2006-01-16 06:47 EST, Caolan McNamara
no flags Details

  None (edit)
Description Caolan McNamara 2006-01-16 06:46:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
evolution crashes on some asian spam mails I seem to get a lot of, reproducable standalone pango test case attached

Version-Release number of selected component (if applicable):
pango-1.11.1-2

How reproducible:
Always

Steps to Reproduce:
1. gcc -g pango-test.c `pkg-config --cflags gtk+-2.0 --libs gtk+-2.0`
2. ./a.out
  

Actual Results:  valid is 1
pLayout is 92b4c78
text is &#20489;&#30000;&#20140;&#23376; <omx100518@yahoo.co.jp>

Pango-ERROR **: file basic-fc.c: line 347 (basic_engine_shape): assertion failed: (face != NULL)
aborting...
Trace/breakpoint trap


Expected Results:  no assert/crash

Additional info:

affects evolution a lot for me
Comment 1 Caolan McNamara 2006-01-16 06:47:16 EST
Created attachment 123232 [details]
testcase
Comment 2 Caolan McNamara 2006-01-18 08:13:58 EST
fonts-japanese needs to be installed to see the crash
Comment 3 Matthias Clasen 2006-01-18 09:42:35 EST
I have fonts-japanese installed, and still don't see the crash...
Comment 4 Ulrich Drepper 2006-01-20 11:31:19 EST
I had similar although not quite the same issues.

The problem was the rename of the directory containing the files.  It used to be
ja, now it's japanese (and similar for korean and chinese).  rpm removed the
font files but the fc caches remained.  fontconfig is broken enough to find
those caches, tries to load the fonts, which fails, and then frees the fonts
anyway.  The freeing is what causes trouble for me.

In this case here it's likely just the loading part: font found in cache, the
load is expected to work but doesn't.
Comment 5 sangu 2006-01-25 08:14:58 EST
$ rpm -q fontconfig
fontconfig-2.3.93.cvs20060124-1

$ gcc -g pango-test.c -o pango-test `pkg-config --cflags gtk+-2.0 --libs gtk+-2.0`
pango-test.c: In function ‘main’:
pango-test.c:36: warning: assignment makes pointer from integer without a cast
[sangu@sangu ~]$ ./pango-test
valid is 1
pLayout is 9e74458
text is 倉田京子 <omx100518@yahoo.co.jp>
line count is 1

Is this problem Fixed in fontconfig-2.3.93.cvs20060124-1?

Please see also bug 176409 .
Comment 6 Matthias Clasen 2006-01-25 08:16:53 EST
Looks like it, doesn't it ?
Comment 7 Behdad Esfahbod 2006-01-26 02:38:46 EST
Well, what Ulrich explains may be one case.  Now that you say fonts-japanese,
makes me believe it's the bug that I tracked down today.

The symptom was that a bunch of fonts shipped with Fedora, when chosen in the
font dialog in gedit for example, crash it.  They typically have three letter
lowercase names.  The one I test with is called "sys", and is actually this file:

  /usr/share/fonts/japanese/misc/mplus_s10-euro.pcf.gz

It's a completely another issue that why are we shipping bitmap fonts in
/usr/share/fonts, but anyway.  I debugged it a few hours ago and seems like the
pproblem is that the font contains 0x0 glyphs, and cairo has a bug with bitmap
0x0 glyphs, causing a crash.  I have reported the bug here:

  http://lists.freedesktop.org/archives/cairo/2006-January/006207.html

And the crash I was getting was indeed in the same place as reported in this
bug.  So I believe that's the cause.  This is going to be fixed soon and hit
cairo 1.2, and I'm planning to require cairo 1.2 for pango 1.12, so it should be
fixed in FC5...

Note You need to log in before you can comment on or make changes to this bug.