Bug 177918 - g++ compiler crashes with internal compiler error
g++ compiler crashes with internal compiler error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 177919 177920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 09:16 EST by Darius Burschka
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.0-0.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 03:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
report file from the compiler after the crash (955.39 KB, text/plain)
2006-01-16 10:53 EST, Darius Burschka
no flags Details

  None (edit)
Description Jakub Jelinek 2006-01-16 09:55:27 EST
Empty bug reports aren't really very useful.
Comment 1 Jakub Jelinek 2006-01-16 09:56:00 EST
*** Bug 177919 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2006-01-16 09:56:27 EST
*** Bug 177920 has been marked as a duplicate of this bug. ***
Comment 3 Darius Burschka 2006-01-16 10:07:50 EST
(In reply to comment #0)
> Empty bug reports aren't really very useful.

Hi... the empty comment was due to internal webserver error at RedHat

I tried to submit a bug report to gcc-c++-4.0.2-8.fc4, but I am getting
an internal webserver error...what is the bug report about?

g++ compiler crashes with internal compiler error 

g++ -O6 -pipe -DDEBUG_LEVEL=1 -DHAVE_CONFIG_H  -I../..//include
-I/usr/X11R6/include  -c -o XVAffineWarp.o XVAffineWarp.cc
XVAffineWarp.cc: In member function â:
XVAffineWarp.cc:163:   instantiated from here
XVAffineWarp.cc:116: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccLsWvq8.out file, please attach
this to your bugreport.

happens every time

way to reproduce
1. download http://robotvision.dynalias.com/XVision.tgz
2. tar xvfz XVision2.tgz
3. cd XVision2;make config
4. cd src/Images;make

actual result
XVColorBase.cc: In member function â:
XVColorBase.cc:30: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make: *** wait: No child processes.  Stop.
make: *** Waiting for unfinished jobs....
make: *** wait: No child processes.  Stop.

It is a template related problem that started with the 4.0 version of
the gcc compiler. It is still not fixed.

Best regards
  Darius Burschka
Comment 4 Jakub Jelinek 2006-01-16 10:22:32 EST
Preprocessed source stored into /tmp/ccLsWvq8.out file, please attach
this to your bugreport.
Comment 5 Darius Burschka 2006-01-16 10:53:19 EST
Created attachment 123238 [details]
report file from the compiler after the crash

here is the requeste report file... I re-created it by running the compiler
again so it has a different name, but it is from the same source file
Comment 7 Jakub Jelinek 2006-01-18 03:03:14 EST
Should be fixed in gcc-4.1.0-0.15 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.