Bug 177949 - Connector crash after eds upgrade this weekend
Connector crash after eds upgrade this weekend
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 14:23 EST by Ryan Skadberg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 16:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2006-01-16 14:23:40 EST
Here's the BT:

[skadz@codewarrior ~]$ gdb /usr/libexec/evolution/2.6/evolution-exchange-storage
GNU gdb Red Hat Linux (6.3.0.0-1.94rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /usr/libexec/evolution/2.6/evolution-exchange-storage
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xa46000
[Thread debugging using libthread_db enabled]
[New Thread -1208727888 (LWP 4450)]
[New Thread -1210827872 (LWP 4455)]
Evolution Exchange Storage up and running
[New Thread -1211094112 (LWP 4477)]

Bonobo-CRITICAL **: bonobo_object_corba_objref: assertion `BONOBO_IS_OBJECT
(object)' failed
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread -1211094112 (LWP 4477)]
IA__g_logv (log_domain=Variable "log_domain" is not available.
) at gmessages.c:502
502               depth--;
(gdb) thread apply all bt

Thread 3 (Thread -1211094112 (LWP 4477)):
#0  IA__g_logv (log_domain=Variable "log_domain" is not available.
) at gmessages.c:502
#1  0x0034f857 in IA__g_log (log_domain=0x15713b "Bonobo",
    log_level=G_LOG_LEVEL_CRITICAL,
    format=0x3762af "%s: assertion `%s' failed") at gmessages.c:517
#2  0x0034f925 in IA__g_return_if_fail_warning (log_domain=0x15713b "Bonobo",
    pretty_function=0x159752 "bonobo_object_corba_objref",
    expression=0x15801b "BONOBO_IS_OBJECT (object)") at gmessages.c:532
#3  0x00133f67 in bonobo_object_corba_objref (object=0x0)
    at bonobo-object.c:1222
#4  0x071d3d6a in impl_CalFactory_getCal (servant=0x926ba44,
    source_xml=0x92a4681 "<?xml version=\"1.0\"?>\n<source
uid=\"1113653381.3490.2@codewarrior.stigmata.org\" name=\"Personal\"
relative_uri=\"system\" color=\"e5e5e5\"
uri=\"file:///home/skadz/.evolution/calendar/local/system\"><propertie"...,
type=1, listener=0x92a0cb0, ev=0xb7d02378) at e-data-cal-factory.c:241
#5  0x071c4b50 in _ORBIT_skel_small_GNOME_Evolution_Calendar_CalFactory_getCal
    (_o_servant=0x926ba44, _o_retval=0xb7d02230, _o_args=0xb7d02210,
    _o_ctx=0xb7d022a8, _o_ev=0xb7d02378,
    _impl_getCal=0x71d3bd4 <impl_CalFactory_getCal>)
    at Evolution-DataServer-Calendar-common.c:244
#6  0x0094c9bb in IOP_start_profiles () from /usr/lib/libORBit-2.so.0
#7  0x0095256b in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
---Type <return> to continue, or q <return> to quit---
#8  0x0094098b in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0
#9  0x00950389 in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#10 0x009509f0 in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#11 0x00939c9b in giop_thread_queue_process () from /usr/lib/libORBit-2.so.0
#12 0x0093a5a3 in giop_init () from /usr/lib/libORBit-2.so.0
#13 0x00364f52 in g_thread_pool_thread_proxy (data=0x9269c80)
    at gthreadpool.c:172
#14 0x003632a4 in g_thread_create_proxy (data=0x92a3c40) at gthread.c:582
#15 0x00db8262 in start_thread (arg=0xb7d02ba0) at pthread_create.c:261
#16 0x0023714e in ?? () from /lib/libc.so.6

Thread 2 (Thread -1210827872 (LWP 4455)):
#0  0x00a46402 in __kernel_vsyscall ()
#1  0x0022dc10 in *__GI___poll (fds=0x292ff4, nfds=9, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0034a5af in g_main_context_iterate (context=0x927b908, block=1,
    dispatch=1, self=0x927a760) at gmain.c:2849
#3  0x0034a8be in IA__g_main_loop_run (loop=0x9271ed8) at gmain.c:2751
#4  0x00957a55 in link_set_io_thread () from /usr/lib/libORBit-2.so.0
#5  0x003632a4 in g_thread_create_proxy (data=0x927a760) at gthread.c:582
#6  0x00db8262 in start_thread (arg=0xb7d43ba0) at pthread_create.c:261
---Type <return> to continue, or q <return> to quit---
#7  0x0023714e in ?? () from /lib/libc.so.6

Thread 1 (Thread -1208727888 (LWP 4450)):
#0  0x00a46402 in __kernel_vsyscall ()
#1  0x0022dc10 in *__GI___poll (fds=0x292ff4, nfds=6, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0034a5af in g_main_context_iterate (context=0x9268668, block=1,
    dispatch=1, self=0x924d480) at gmain.c:2849
#3  0x0034a8be in IA__g_main_loop_run (loop=0x927deb8) at gmain.c:2751
#4  0x0012f649 in bonobo_main () at bonobo-main.c:312
#5  0x0805f9b7 in main (argc=1, argv=Cannot access memory at address 0xa
) at main.c:238
#6  0x001856b4 in __libc_start_main (main=0x805f4b8 <main>, argc=1,
    ubp_av=0xbfe72fe4, init=0x80a1f10 <__libc_csu_init>,
    fini=0x80a1f08 <__libc_csu_fini>, rtld_fini=0xd54dd0 <_dl_fini>,
    stack_end=0xbfe72fdc) at libc-start.c:231
#7  0x0805b231 in _start ()
(gdb) Quit
(gdb)
Comment 1 Dave Malcolm 2006-01-16 17:59:15 EST
Thanks for this bug report.

It looks like another warning (about a bug) that became a fatal error with the
gnome-session upgrade  (NULL object passed to bonobo_object_corba_objref by
impl_CalFactory_getCal).

Please can you file a bug about this in the upstream tracker at bugzilla.gnome.org

Comment 2 Ryan Skadberg 2006-01-17 16:32:58 EST
Escellated upstream as:

http://bugzilla.gnome.org/show_bug.cgi?id=327427

And closing ...

Note You need to log in before you can comment on or make changes to this bug.