Bug 177973 - pirut traceback removing kde
pirut traceback removing kde
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 177979 178147 178721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 18:04 EST by Jason
Modified: 2009-01-07 20:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 12:27:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 123 None None None Never

  None (edit)
Description Jason 2006-01-16 18:04:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
When I try to remove kde I get the following:

Component: Software Manager
Summary: TBb4cd5369 __init__.py:410:depDetails:NameError: global name 'pango' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 298, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 536, in applyChanges
    self.depDetails(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 410, in depDetails
    tag.set_property('weight', pango.WEIGHT_BOLD)
NameError: global name 'pango' is not defined

Local variables in innermost frame:
mainwin: <gtk.Window object (GtkWindow) at 0xb74c75cc>
self: <__main__.PackageManager object at 0xb7a467ec>
b: <gtk.TextBuffer object (GtkTextBuffer) at 0xb27e339c>
tag: <gtk.TextTag object (GtkTextTag) at 0xb27e34dc>
d: <pirut.DetailsDialog.PirutDetailsDialog instance at 0xb388410c>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install kde
2.  switch to gnome
3.  try to remove kde
  

Actual Results:  traceback

Expected Results:  remove kde

Additional info:
Comment 1 Jeremy Katz 2006-01-18 12:27:22 EST
Fixed in CVS
Comment 2 Jeremy Katz 2006-01-18 12:27:44 EST
*** Bug 177979 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-01-18 12:28:05 EST
*** Bug 178147 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2006-01-23 14:41:48 EST
*** Bug 178721 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.