Bug 177984 - Chooser fails silently (no message) without directory permissions
Chooser fails silently (no message) without directory permissions
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 181053 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 18:57 EST by Gianluca Cecchi
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-07 08:01:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sometimes I get the file attached when doble click dir without permissions (11.00 KB, text/plain)
2006-01-16 18:57 EST, Gianluca Cecchi
no flags Details
Console crash debug information, reproducing crash for this bug (5.77 KB, text/plain)
2006-01-24 00:26 EST, Wade Mealing
no flags Details
Gimp crash, doing the same procedure. (4.00 KB, text/plain)
2006-01-24 00:28 EST, Wade Mealing
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 332245 None None None Never

  None (edit)
Description Gianluca Cecchi 2006-01-16 18:57:19 EST
Description of problem:
when I navigate through file system to find file to play, if I try to enter a
directory where I have no permission for, totem crashes with the message:
the application totem has quit unexpectedly

Version-Release number of selected component (if applicable):
totem-1.3.0-3

How reproducible:
always

Steps to Reproduce:
1.open totem
2.movie --> open... ---> navigate file system
3.when double click on dir without permission to change into, you get the crash
  
Actual results:
totem crashed

Expected results:
message like permission denied.

Additional info:
problem only trying to open dirs, not with files without permission.
In this case I correctly get: " an error occured. Can not open resource for reading"
If run from command line, sometimes I get together with the crash the error
libgnomevfs-CRITICAL **: gnome_vfs_uri_extract_dirname: assertion `uri != NULL'
failed
Comment 1 Gianluca Cecchi 2006-01-16 18:57:19 EST
Created attachment 123273 [details]
sometimes I get the file attached when doble click dir without permissions
Comment 2 Gianluca Cecchi 2006-01-16 19:15:26 EST
It seems a general file system navigation problem.
I get the error also in gedit and gimp.
Sorry.
Is it possible to post the bug under another application? Which one?
Gianluca
Comment 3 Wade Mealing 2006-01-24 00:14:00 EST
Ok.. was able to reproduce this crash, looks like it the problem is in gnome-vfs.

# as root
mkdir /home/wmealing/test
chown root.root /home/wmealing/test/
chmod 0000 /home/wmealing/test/
Attaching the crash data momentarily.
Comment 4 Wade Mealing 2006-01-24 00:26:20 EST
Created attachment 123600 [details]
Console crash debug information, reproducing crash for this bug

Looks like a gnome-vfs problem , rather than a totem issue.
Comment 5 Wade Mealing 2006-01-24 00:28:04 EST
Created attachment 123601 [details]
Gimp crash, doing the same procedure.

Console debug output for gimp
Comment 6 Wade Mealing 2006-01-24 00:28:50 EST
[wmealing@localhost ~]$ rpm -qa | grep vfs
gnome-vfs2-devel-2.13.3-3
gnome-vfs2-smb-2.13.3-3
gnome-vfs2-2.13.3-3
gnome-python2-gnomevfs-2.12.1-1.2
[wmealing@localhost ~]$ rpm -q gimp
gimp-2.2.10-2
[wmealing@localhost ~]$ rpm -q totem
totem-1.3.0-3
Comment 7 John (J5) Palmieri 2006-01-24 09:42:30 EST
CC'ed bnocera and reassigned to Ray.
Comment 8 Bastien Nocera 2006-01-24 09:59:14 EST
That's a gnome-vfs crash, nothing to do with Totem.
Comment 9 Alexander Larsson 2006-01-25 04:15:31 EST
This looks like a bad free in the inotify code. Can anyone try this with
debuginfo packages installed?
Comment 10 Gianluca Cecchi 2006-01-31 16:13:04 EST
Now with gimp and totem, you get no errors or crashes, but in my opinion the
behaviour is not correct:
you seem to navigate inside the directory where you have no rights for (es 700
and you are not the owner), and you see no files in it.
You don't receive any permission denied error...

[gcecchi@fedora ~]$ rpm -qa | grep vfs
gnome-python2-gnomevfs-2.12.1-1.2
gnome-vfs2-devel-2.13.4-4
gnome-vfs2-2.13.4-4
gnome-vfs2-smb-2.13.4-4
[gcecchi@fedora ~]$ rpm -q totem
totem-1.3.90-1
[gcecchi@fedora ~]$ rpm -q gimp
gimp-2.2.10-2
Comment 11 Gianluca Cecchi 2006-01-31 16:16:49 EST
with file explorer instead for example, when trying to go inside directory
without r-x permission, you get pop up window with:
"The folder contents could not be displayed.
You do not have the permissions necessary to view the contents of "dirname"."
Comment 12 Matthias Clasen 2006-02-16 10:44:04 EST
hmm, the instructions in comment #3 don't crash for me.
I do see crashes with a locally built old gnome-vfs, though.

Wade, do you still see this ?
Comment 13 Gianluca Cecchi 2006-02-16 11:40:26 EST
hey,
it's about one month from initial post and many versions of the various packages
involved changed.
See #10 and #11 where no more errors, but see also my comments about silent
behaviour...
this evening I will try with latest packages installed, in particular with

gnome-vfs2-2.13.91-1
and
totem-1.3.91-1
and
gimp-2.2.10-2.2

and let know.
Comment 14 Matthias Clasen 2006-02-16 13:34:40 EST
the silent behaviour will be a bit more work to fix in the file chooser,
not fc5blocker material.
Comment 15 Gianluca Cecchi 2006-02-17 04:11:35 EST
ok, in the mean time I confirmed the silent behaviour with the versions in
#13 and overall packages updated as of "rawhide report: 20060216 changes"
Comment 16 Alexander Larsson 2006-02-17 09:23:45 EST
*** Bug 181053 has been marked as a duplicate of this bug. ***
Comment 17 Rahul Sundaram 2006-02-20 06:34:19 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 18 Matthias Clasen 2006-02-23 23:26:03 EST
I haven't been able to reproduce the crash from the file chooser of nautilus 
when navigating to an unreadable folder with recent versions of gnome-vfs.
Can anybody still reproduce this ?
Comment 19 David Nielsen 2006-03-06 20:56:41 EST
Unable to reproduce using method described in comment #3

using:
gnome-vfs2-2.13.92-3
Comment 20 Gianluca Cecchi 2006-03-07 02:04:47 EST
the situation is as detailed in #13 by me and #14 by Matthias Clasen.
So the only problem is that one would expectd a permission denied problem when
navigating inside a folder without permissions for, not the system entering in
it without showing any files/dir and giving no error...
Comment 21 Hans de Goede 2006-03-07 02:46:06 EST
As requested on fedora-devel I'm looking at FC5 blocker bugs as I understand,
from above this one can be removed from the blocker list, shall I?
Comment 22 Gianluca Cecchi 2006-03-07 03:28:45 EST
yes indeed.
Comment 23 John Thacker 2006-06-01 10:25:04 EDT
Changing summary to something describing the current bug; i.e., 
if the user lacks permission to view a directory the file chooser
fails silently, merely not showing files in that directory, rather
than giving an informative error message.  This occurs when browsing
directories using gnome-vfs on, e.g., totem and gimp.
Comment 24 Matthew Miller 2007-04-06 15:51:05 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 25 Hans de Goede 2007-04-07 03:07:57 EDT
I just tried this on a Fedora 7 test / rawhide system last update a couple of
dasy ago and this still happens, bad BAD!

I'll also file this upstream and add a bugzilla reference here.
Comment 26 Matthew Miller 2007-04-07 07:58:56 EDT
Okay, cool. At that point this can be closed as "upstream".
Comment 27 Matthew Miller 2007-04-07 08:01:01 EDT
Oh, hey, like you already did. Time for coffee for me!

Note You need to log in before you can comment on or make changes to this bug.