Bug 177985 - unable to play audio cd
unable to play audio cd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 19:08 EST by Gianluca Cecchi
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 05:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gianluca Cecchi 2006-01-16 19:08:21 EST
Description of problem:
play audio disc is gray, strange behaviour

Version-Release number of selected component (if applicable):
totem-1.3.0-3

How reproducible:
always

Steps to Reproduce:
1.insert audio cd
2.open totem
3.movie---> menu entry "Play disc 'Audio disc'" is gray, no selectable
  
Actual results:
no audio cd selectable

Expected results:
play cd

Additional info:
If I do "open location" and select "/dev/hdc" (my audio cd device)
I get: totem could not play this media (audio cd)
although a plugin is present to handle it
Inside the terminal window where I ran totem, I have:
** Message: bacon-video-widget-gst-0.10.c:3129: Fix CD mrls querying when cd
plugins are ported

After this, if I reselect movie--> I see in the list the line for hdc.
I can select it, but the windows somehow freeezes, it seems to play but
without sound.
[root@fedora ~]# fuser /dev/snd/pcmC0D0p
/dev/snd/pcmC0D0p:    3857m  3862m
and these are the totem processes
I run totem as gcecchi and ll /dev/hdc gives:
brw------- 1 gcecchi disk 22, 0 Jan 17 00:31 /dev/hdc

[gcecchi@fedora ~]$ ll /usr/lib/gnome-vfs-2.0/modules/
total 556
-rwxr-xr-x 1 root root   6908 Jan  9 22:27 libbzip2.so
-rwxr-xr-x 1 root root  15712 Jan  9 22:27 libcomputer.so
-rwxr-xr-x 1 root root  14664 Jan  9 22:27 libdns-sd.so
-rwxr-xr-x 1 root root  40768 Jan  9 22:27 libfile.so
-rwxr-xr-x 1 root root  14516 Jan 13 17:41 libfont-method.so
-rwxr-xr-x 1 root root  32140 Jan  9 22:27 libftp.so
-rwxr-xr-x 1 root root   8604 Jan  9 22:27 libgzip.so
-rwxr-xr-x 1 root root 122748 Jan  9 22:27 libhttp.so
-rwxr-xr-x 1 root root  22940 Dec 15 19:24 libmapping.so
-rwxr-xr-x 1 root root  17404 Jan  9 22:27 libnetwork.so
-rwxr-xr-x 1 root root  22672 Jan  9 22:27 libnntp.so
-rwxr-xr-x 1 root root  16868 Dec 20 19:58 libpythonmethod.so
-rwxr-xr-x 1 root root  32028 Jan  9 22:27 libsftp.so
-rwxr-xr-x 1 root root  27160 Jan  9 22:27 libsmb.so
-rwxr-xr-x 1 root root  11192 Jan  9 22:27 libtar.so
-rwxr-xr-x 1 root root 110604 Jan 13 17:41 libtheme-method.so
-rwxr-xr-x 1 root root  14420 Jan  9 22:27 libvfs-test.so

Perhaps something related with bug 137250?
Comment 1 John (J5) Palmieri 2006-01-16 19:18:29 EST
** Message: bacon-video-widget-gst-0.10.c:3129: Fix CD mrls querying when cd
plugins are ported

Looks like CD playing is not yet fixed upstream in the gstreamer 0.10 branch.
Comment 2 Bastien Nocera 2006-01-17 05:03:58 EST
From the NEWS file:

1.3.0:
New features:
<snip>
  * Remove audio CD playback from the UI, as to avoid duplication with sound-
  juicer and Rhythmbox

Note You need to log in before you can comment on or make changes to this bug.