Bug 177992 - slibcat file refers to umb-scheme instead of guile
slibcat file refers to umb-scheme instead of guile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 21:39 EST by swader
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 07:04:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description swader 2006-01-16 21:39:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.8.3

Description of problem:
Gnucash built from the current trunk on subversion crashed with
a file not found on "/usr/share/umb-scheme/slib/printf". I rebuilt
the slibcat file with 
   # guile
   guile> (use-modules (ice-9 slib))
   guile> (load "/usr/local/share/slib/mklibcat.scm")
   guile> (quit)
from the guile reference manual and it fixed the problem.


Version-Release number of selected component (if applicable):
guile-1.6.7-2

How reproducible:
Always

Steps to Reproduce:
1.build gnucash from subversion
2.lauch gnucash
3.
  

Actual Results:  crashes in scm_boot_guile routine with file not found error

Additional info:
Comment 1 Miroslav Lichvar 2006-01-17 07:04:45 EST
The easiest solution is to install the umb-scheme package, it contains the
missing file and fc4 gnucash depends on it anyway. The problem is already fixed
in rawhide, where the umb-scheme dependency is dropped.

Note You need to log in before you can comment on or make changes to this bug.