Bug 178015 - gnome-terminal-2.13.2-1 crashes on startup - Gtk-CRITICAL **: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
gnome-terminal-2.13.2-1 crashes on startup - Gtk-CRITICAL **: gtk_label_set_t...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 178046 178071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 07:37 EST by James Laska
Modified: 2013-09-02 02:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-04 00:30:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2006-01-17 07:37:56 EST
$ rpm -q gnome-terminal
gnome-terminal-2.13.2-1.i386

After upgrading to 2.13.2-1, gnome-terminal crashes on startup.  If I roll back
to 2.13.1-1 I do not experience the error.

[jlaska@flatline ~]$ gdb /usr/bin/gnome-terminal

GNU gdb Red Hat Linux (6.3.0.0-1.98rh)

Copyright 2004 Free Software Foundation, Inc.

GDB is free software, covered by the GNU General Public License, and you are

welcome to change it and/or distribute copies of it under certain conditions.

Type "show copying" to see the conditions.

There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".



(gdb) r

Starting program: /usr/bin/gnome-terminal 

Reading symbols from shared object read from target memory...done.

Loaded system supplied DSO at 0xcbd000

[Thread debugging using libthread_db enabled]

[New Thread -1208224080 (LWP 4142)]



** (gnome-terminal:4142): WARNING **: Error compiling regular expression
"\<(file:///(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) 	


,\"])?".

Detaching after fork from child process 4145.

Detaching after fork from child process 4146.

[New Thread -1214252128 (LWP 4147)]



(gnome-terminal:4142): GLib-GObject-WARNING **: invalid cast from `GtkEventBox'
to `GtkLabel'



Gtk-CRITICAL **: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed

aborting...



Program received signal SIGTRAP, Trace/breakpoint trap.

[Switching to Thread -1208224080 (LWP 4142)]

IA__g_logv (log_domain=Variable "log_domain" is not available.

) at gmessages.c:502

502		  depth--;

(gdb) bt

#0  IA__g_logv (log_domain=Variable "log_domain" is not available.

) at gmessages.c:502

#1  0x005c4e47 in IA__g_log (log_domain=0x4d9c3c7 "Gtk",
log_level=G_LOG_LEVEL_CRITICAL, format=0x5ec04f "%s: assertion `%s' failed") at
gmessages.c:517

#2  0x005c4f15 in IA__g_return_if_fail_warning (log_domain=0x4d9c3c7 "Gtk",
pretty_function=0x4e1172e "gtk_label_set_text", 

    expression=0x4e10b1e "GTK_IS_LABEL (label)") at gmessages.c:532

#3  0x04c8d0f5 in gtk_label_set_text () from /usr/lib/libgtk-x11-2.0.so.0

#4  0x080730d5 in sync_label (screen=0x94cf730, nb=0x9515018) at
terminal-notebook.c:715

#5  0x003868b8 in IA__g_cclosure_marshal_VOID__VOID (closure=0x9526e58,
return_value=0x0, n_param_values=1, param_values=0xbfbdcb6c, 

    invocation_hint=0xbfbdca4c, marshal_data=0x807304a) at gmarshal.c:77

#6  0x00379dba in IA__g_closure_invoke (closure=0x9526e58, return_value=0x0,
n_param_values=1, param_values=0xbfbdcb6c, invocation_hint=0xbfbdca4c)

    at gclosure.c:490

#7  0x0038af78 in signal_emit_unlocked_R (node=0x95260d8, detail=0,
instance=0x94cf730, emission_return=0x0, instance_and_params=0xbfbdcb6c)

    at gsignal.c:2438

#8  0x0038c3f2 in IA__g_signal_emit_valist (instance=0x94cf730, signal_id=132,
detail=0, 

    var_args=0x38c427
"\213\205äýÿÿ\205À\017\204\177øÿÿ\213\215äýÿÿ\211\f$è©­þÿéløÿÿ\215\203\224\003")
at gsignal.c:2197

#9  0x0038c695 in IA__g_signal_emit (instance=0x94cf730, signal_id=132,
detail=0) at gsignal.c:2241

#10 0x08068dfc in terminal_screen_cook_title (screen=0x94cf730) at
terminal-screen.c:729

#11 0x0806a391 in terminal_screen_set_dynamic_title (screen=0x94cf730,
title=0x9525258 "jlaska@flatline:~/public_html/sqlobject", userset=0)

    at terminal-screen.c:1839

#12 0x0806b210 in terminal_screen_widget_title_changed (widget=0x94db628,
screen=0x94cf730) at terminal-screen.c:2017

#13 0x003868b8 in IA__g_cclosure_marshal_VOID__VOID (closure=0x95f63b8,
return_value=0x0, n_param_values=1, param_values=0xbfbdd02c, 

    invocation_hint=0xbfbdcf0c, marshal_data=0x806b1e7) at gmarshal.c:77

#14 0x00379dba in IA__g_closure_invoke (closure=0x95f63b8, return_value=0x0,
n_param_values=1, param_values=0xbfbdd02c, invocation_hint=0xbfbdcf0c)

    at gclosure.c:490

#15 0x0038af78 in signal_emit_unlocked_R (node=0x9527a68, detail=0,
instance=0x94db628, emission_return=0x0, instance_and_params=0xbfbdd02c)

    at gsignal.c:2438

#16 0x0038c3f2 in IA__g_signal_emit_valist (instance=0x94db628, signal_id=138,
detail=0, var_args=0x0) at gsignal.c:2197

#17 0x0038d73f in IA__g_signal_emit_by_name (instance=0x94db628,
detailed_signal=0x298f17 "window-title-changed") at gsignal.c:2265

#18 0x0021584b in vte_terminal_erase_binding_get_type () from /usr/lib/libvte.so.4

#19 0x00215923 in vte_terminal_erase_binding_get_type () from /usr/lib/libvte.so.4

#20 0x0021e5de in vte_terminal_copy_clipboard () from /usr/lib/libvte.so.4

#21 0x0021e7b0 in vte_terminal_copy_clipboard () from /usr/lib/libvte.so.4

#22 0x005bd0f0 in g_timeout_dispatch (source=0x962b250, callback=0x21e794
<vte_terminal_copy_clipboard+3113>, user_data=0x94db628) at gmain.c:3292

#23 0x005bca43 in IA__g_main_context_dispatch (context=0x94d2830) at gmain.c:1916

#24 0x005bfa83 in g_main_context_iterate (context=0x94d2830, block=1,
dispatch=1, self=0x94d6d98) at gmain.c:2547

#25 0x005bfe2c in IA__g_main_loop_run (loop=0x9577040) at gmain.c:2751

#26 0x04c9cfec in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0

#27 0x0805ee99 in main (argc=Cannot access memory at address 0x0

) at terminal.c:1773

#28 0x0064d6b4 in __libc_start_main () from /lib/libc.so.6

#29 0x08054641 in _start ()

(gdb) quit

The program is running.  Exit anyway? (y or n) y
Comment 1 Jeremy Fitzhardinge 2006-01-18 13:04:44 EST
I see this too.  gnome-terminal crashes with:

$ gnome-terminal

** (gnome-terminal:30058): WARNING **: Error compiling regular expression
"\<(file:///(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) 
,\"])?".

(gnome-terminal:30058): GLib-GObject-WARNING **: invalid cast from `GtkEventBox'
to `GtkLabel'

Gtk-CRITICAL **: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
aborting...
exit status 1
Comment 2 Jeremy Fitzhardinge 2006-01-18 13:08:31 EST
Oh, and gnome-volume-control and stickynotes_applet both crash on login in
similar ways (ie, apparently as the result of Gtk-CRITICAL messages.
Comment 3 Pierre Ossman 2006-01-19 04:28:01 EST
Most of the crashing went away with tonights updates. The only thing that still
goes poof is gnome-volume-manager.
Comment 4 John Ellson 2006-01-26 08:25:33 EST
gnome-terminal-2.13.3-1.x86_64 still crashes reliably for me when starting
multiple ssh sessions with the bash script:
--------------------------------------
#!/bin/sh
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
gnome-terminal -x ssh localhost &
---------------------------------------
reverting to gnome-terminal-2.12.0-2.x86_64 fixes the problem.
gnome-terminal -x ssh localhost &
Comment 5 Need Real Name 2006-01-26 12:20:51 EST
(In reply to comment #4)
> gnome-terminal-2.13.3-1.x86_64 still crashes re

Same for me (although the previous problem is fixed for me)
Comment 6 Matthias Clasen 2006-02-04 00:30:10 EST
Fixed in rawhide, I believe
Comment 7 Matthias Clasen 2006-02-04 23:22:50 EST
*** Bug 178046 has been marked as a duplicate of this bug. ***
Comment 8 Behdad Esfahbod 2006-07-27 17:15:30 EDT
*** Bug 178071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.