Bug 178017 - gnome-background-properties crahes when selected background is missing
gnome-background-properties crahes when selected background is missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 08:41 EST by Dana Canfield
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:14:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dana Canfield 2006-01-17 08:41:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Discovered this by setting my background to an image in mmy home directory then absent-mindedly deleting the image.  My background changed to white at the next login, and when I tried to run gnome-background-properties via the right-click menu, the application crashed consistently.  

I was able to work around this by un-setting the key in gconf-editor (at which point g-b-p worked again), but a user without this knowledge would be stuck with a broken background and no way to fix it.

Version-Release number of selected component (if applicable):
control-center-2.13.4-2

How reproducible:
Always

Steps to Reproduce:
1. Set a background image
2. Delete image
3. Run gnome-background-properties
  

Actual Results:  The application gnome-background-properties has unexpectedly quit.

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:36:54 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Dana Canfield 2006-02-20 15:14:30 EST
Didn't test this extensively, but at first glance, it seems this was fixed
somewhere along the way.

Note You need to log in before you can comment on or make changes to this bug.