Bug 178022 - Authentification Configuration cannot be run
Authentification Configuration cannot be run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setuptool (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 09:25 EST by Philippe Rigault
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 09:07:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2006-01-17 09:25:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; en_US, fr) KHTML/3.5.0 (like Gecko)

Description of problem:
It is impossible to run the 'Authentification Configuration' part of the setup  
tool. This is rather important and must be fixed before fc5 final. 
 
Note: The component that has the bug may be authconfig instead of setuptool. 

Version-Release number of selected component (if applicable):
setuptool-1.17.3-1.1

How reproducible:
Always

Steps to Reproduce:
1. Install fc5test2  
2. Log in as root 
3. Run /usr/sbin/setup in a terminal  
3. Select 'Authentification Configuration' 'Run Tool'  
    

Actual Results:  The terminal switches from the blue-and-red setup colors back to the original 
terminal schema colors, the  authconfig 'usage' message appears on the 
terminal for a short period of time, and then the blue-and-red main setup menu 
reappears. All this happens in a very short period of time (~0.3s). 

Expected Results:  The menu for Authentification Configuration (authconfig) should appear. 

Additional info:

It looks like running 'Authentification Configuration' executes authconfig  
with the wrong options/context, resulting in an error and the 'usage' printed.
Comment 1 Nalin Dahyabhai 2006-01-17 14:18:49 EST
The setuptool launcher is attempting to run
"/usr/share/authconfig/authconfig-tui.py".  To help narrow
this down, are you able to run this script directly?
Comment 2 Philippe Rigault 2006-01-17 15:43:25 EST
Running /usr/share/authconfig/authconfig-tui.py works, in that the authconfig 
red-and-blue menu appears and the user can select options. 
Comment 3 Nalin Dahyabhai 2006-01-18 09:07:57 EST
The existing configuration gives /usr/sbin/authconfig and
/usr/share/authconfig/authconfig-tui.py equal precedence, so setuptool was
launching the first one it found.  After fixing that, I noticed that the
precedence-sorting code wasn't working correctly, so that needed to be fixed as
well.  Both will be fixed in 1.18-1.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.