Bug 178103 - Hard drives automagically become /dev/mapper/pdc_jgobbledygook
Hard drives automagically become /dev/mapper/pdc_jgobbledygook
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 15:26 EST by Chris Kloiber
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 15:55:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2006-01-17 15:26:37 EST
Description of problem:

Installing x86_64 version of FC5-Test2 on ASUS K8V-SE Deluxe motherboard (AMD64,
sata_via, 2 identical 120 GB SATA drives) is not possible because the drives are
automatically made a part of a dm_raid (I think) that begins with
mapper/pdc_j... Attempting to install to this "device" looks like it works until
you try to reboot, but it won't work. I have tried partitioning/formatting the
disks manually first but the installer ignores existing partitions.

Anaconda will not acknowledge that /dev/sda and /dev/sdb exist nor allow you to
partition or use them.
Comment 1 David Cantrell 2006-01-17 15:42:35 EST
Can you run the installer again, but pass the 'nodmraid' option at the installer
boot prompt?
Comment 2 Chris Kloiber 2006-01-18 14:13:38 EST
Will do so as soon as possible. 

If it stays like this for GOLD, please document in RELEASE-NOTES, thanks. 
Comment 3 Chris Kloiber 2006-01-18 21:14:56 EST
'nodmraid' works. Thanks!
Comment 4 Jeremy Katz 2006-01-31 15:55:15 EST
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.