Bug 17811 - 2.2.16-3+qlogic fc+sym53c896->panic
2.2.16-3+qlogic fc+sym53c896->panic
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-24 11:52 EDT by Pavel Urban
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-24 11:52:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Urban 2000-09-24 11:52:33 EDT
I've recompiled 2.2.16-3 to support QLogic fibre channel card (reported as 'scsi0 : QLogic ISP2100 SCSI on PCI bus 01 device 38 irq 36 base 
0x2000' by 2.2.14-5 with the same compile options). While booting, I get these messages:

...
scsi: unknown type 31
  Vendor:         Model: 0 <ASCII chaos>
  Type: Unknown
<repeated several times>
...
kernel panic

Panic is probably caused by confused kernel which tries to find root filesystem on sdb and there is no second scsi drive present. 

HW: Dell PowerEdge 8450, PowerVault 650F array, 2 Xeons/450, 2g ram, 8.5g scsi disc
Comment 1 Pavel Urban 2000-11-20 10:51:36 EST
It doesn't work even with mainstream 2.2.17. Seems like ql fiber channel support in kernel is broken for Dell's PowerVault. You have to use kernel patch 
from http://www.qlogic.com/bbs-html/csg_web/adapter_pages/driver_pages/21xx/21linux.html instead. They propose that it is for RedHat's 2.2.14-5, but 
it works fine for me with unpatched 2.2.17, too. You just have to adjust line numbers from documentation.

Note You need to log in before you can comment on or make changes to this bug.