Bug 178130 - Fedora won't install on Sun Fire 4200 - No drives found
Fedora won't install on Sun Fire 4200 - No drives found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 17:06 EST by Philippe Rigault
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 13:33:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (7.58 KB, text/plain)
2006-01-18 12:11 EST, Philippe Rigault
no flags Details
/proc/partitions (56 bytes, text/plain)
2006-01-18 12:11 EST, Philippe Rigault
no flags Details
Output of lsmod (1.48 KB, text/plain)
2006-01-18 12:13 EST, Philippe Rigault
no flags Details

  None (edit)
Description Philippe Rigault 2006-01-17 17:06:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; en_US, fr) KHTML/3.5.0 (like Gecko)

Description of problem:
Critical to fix for FC5 IMO, so I set severity to High. 
   
It is critical that Fedora Core be installable on the recently released   
 line of Sun AMD64 servers. These so-called 'Galaxy' servers comprise:    
 - SunFire 4100    
 - SunFire 4200    
 and complement the former line of AMD64 servers (SunFire V20z and V40z) and   
workstations (W1100z/W2100z).   
   
Neither fc3 nor fc5test2 can be installed on the 4100/4200, because they do   
not recognize the hard disks on this hardware.   

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot machine with Fedora install CD/DVD  
2. Select keyboard to use during install, click 'Next' 
3. Select language to use during install, click 'Next' 
      

Actual Results:  Searching for Fedora Core Installations... 
 
No drives Found   
An error has occured - No valid devices were found on which to create  
new file systems. Please check your hardware for the cause of this problem.    

Expected Results:  Drives recognized. Installation goes through. 

Additional info:

Hardware components of SunFire 4200   
   
Two dual-core Opteron CPUs   
4GB RAM   
LSI Logic SAS1064 controller 
Two 2.5" hard disks: Seagate ST973401 73.4 GB - Ultra320 SCSI
Comment 1 Philippe Rigault 2006-01-17 17:10:40 EST
More info on this hardware at: 
http://sk.sun.com/files/06_x86RS_SF_X4100_X4200.pdf 
Comment 2 Philippe Rigault 2006-01-17 17:41:01 EST
FWIW, according to this:  
http://www.lsilogic.com/files/support/ssp/fusionmpt/sas/linux/mptlinux_20624.txt  
the mptlinux drivers support the LSISAS1064 device.  
Comment 3 David Cantrell 2006-01-18 11:05:34 EST
Boot up rescue mode from the installation media.  The 2.6.15 kernel version
3.03.06 of the mptlinux driver from LSI.  It supports your card.  I want to know
if the driver is even loading on this system.

From rescue mode, run lsmod and such to see if mptscsih and mptbase are loaded.
 Attach the output of dmesg to this ticket.  Attach /proc/partitions.  If it
doesn't load on your system, it's going to be a kernel issue and not an
installer issue.
Comment 5 Philippe Rigault 2006-01-18 12:11:11 EST
Created attachment 123389 [details]
dmesg
Comment 6 Philippe Rigault 2006-01-18 12:11:47 EST
Created attachment 123390 [details]
/proc/partitions
Comment 7 Philippe Rigault 2006-01-18 12:13:08 EST
Created attachment 123391 [details]
Output of lsmod

Neither mptbbase nor mptscsih are loaded.
Comment 8 Philippe Rigault 2006-01-18 12:17:28 EST
Additional info: 
 
1. modprobe exits with an error 
 
# modprobe mptbase 
modprobe: could not parse modules.dep 
 
# modprobe usb-storage 
modprobe: could not parse modules.dep 
 
2. I attached a USB key to the system (wanted to saves files there). 
The disk is recognized: 
usb 2-3.1: new full speed USB device using ohci_hcd and address 5 
scsi2 : SCSI emulation for USB Mass Storage devices 
usb-storage: device found at 5 
usb-storage: waiting for device to settle before scanning 
  Vendor: CRUCIAL   Model: USB DRIVE         Rev: 1.11 
  Type:   Direct-Access                      ANSI SCSI revision: 01 CCS 
SCSI device sdi: 503808 512-byte hdwr sectors (258 MB) 
sdi: Write Protect is off 
sdi: Mode Sense: 23 00 00 00 
sdi: assuming drive cache: write through 
SCSI device sdi: 503808 512-byte hdwr sectors (258 MB) 
sdi: Write Protect is off 
sdi: Mode Sense: 23 00 00 00 
sdi: assuming drive cache: write through 
 sdi: sdi1 
sd 2:0:0:0: Attached scsi removable disk sdi 
usb-storage: device scan complete 
 
However, the disk cannot be seen by fdisk. The usb-storage module is there 
tough. 
 
# fdisk /dev/sdi 
Unable to open /dev/sdi 
 
Comment 9 David Cantrell 2006-01-18 13:33:00 EST
Jeremy: whoops.  Added mptsas to module-info.
Comment 10 Philippe Rigault 2006-01-18 13:47:28 EST
Is there any workaround (e.g boot option) to get the install of fc5 to 
proceed ?  
 
I have this hardware at hand only for a short time (2 weeks), so it is 
critical to me that I can start testing Fedora on them asap. 
 
 
 
Comment 11 David Cantrell 2006-01-18 13:51:33 EST
The fix is in now, so it'll be in the FC5 Test 3.  I could make a boot iso from
rawhide for you, or you could make one tomorrow.  Other than that, I say wait
for Test 3.
Comment 12 Philippe Rigault 2006-01-18 14:12:25 EST
I can't wait for test3, and I also would rather ensure that the fix is  
validated before test3.  
The first solution is appealing, that would be very kind of you. 
I can also make a boot iso myself if you point me to instructions on how to. 
Also, how can one run the install using a boot iso disk ? 
Comment 13 David Cantrell 2006-01-18 14:15:10 EST
I can't wait for test3 either.  It's going to be awesome.

Now is not the best time to crank off an iso from rawhide.  Let me do that
tomorrow and then send you a URL where to download it.  You'll have to do an
HTTP install because I'm only going to make the boot iso.

Email me directly to remind me.
Comment 14 Philippe Rigault 2006-01-20 15:49:59 EST
Confirmed fixed, mptsas loads and disks are recognized. 

Note You need to log in before you can comment on or make changes to this bug.