Bug 178136 - Conflicts: fontconfig > = 2.3.0 prevents installation of dejavu-fonts-2.2-2
Conflicts: fontconfig > = 2.3.0 prevents installation of dejavu-fonts-2.2-2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dejavu-fonts (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 18:22 EST by Jason Tibbitts
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 16:26:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2006-01-17 18:22:58 EST
I cannot install or update dejavu-fonts:

 s yum update dejavu-fonts
Setting up Update Process
Setting up Repos
base                      100% |=========================|  951 B    00:00
updates                   100% |=========================|  951 B    00:00
local                     100% |=========================| 1.1 kB    00:00
extras                    100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 1676/1676
updates   : ################################################## 957/957
local     : ################################################## 78/78
extras    : ################################################## 2062/2062
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package dejavu-fonts.noarch 0:2.2-2.fc3 set to be updated
--> Running transaction check
--> Processing Conflict: dejavu-fonts conflicts fontconfig > =
--> Finished Dependency Resolution
Error: dejavu-fonts conflicts with fontconfig > =

I'm not sure what the issue is here.  Perhaps the space between ">" and "="?
Comment 1 Nicolas Mailhot 2006-01-17 18:47:07 EST
Probably. I always mess up this operator ;(
My rpm doc says the space isn't needed so I'll push a new build without it
Don't know what rpm version FC-3 actually uses
Comment 2 Nicolas Mailhot 2006-01-17 18:49:24 EST
Well, the buildsys is dead so you'll have to wait some more time
Comment 3 Jason Tibbitts 2006-01-17 18:57:16 EST
FC3 is at rpm 4.3.2 (rpm-4.3.2-21).

It looks like it's seeing the Conflicts: line and checking whether the version
of fontconfig is greater than "=".

I'll test with a build from CVS.

....

Yep, it works fine.
Comment 4 Nicolas Mailhot 2006-01-17 19:09:02 EST
ok, thanks

will push asap
Comment 5 Roozbeh Pournader 2006-01-18 08:57:58 EST
The bug is also there on FC4. 
Comment 6 Roozbeh Pournader 2006-01-18 08:59:54 EST
Changing severity to high since this stops FC4 machines with dejavu-fonts from
getting updated: yum update fails because of the error.
Comment 7 Nicolas Mailhot 2006-01-18 09:19:44 EST
FC-4 & FC-3 share the same spec
It's fixed in CVs but with my luck by the time I have ssh access the buildsys
will be unresponding again
Comment 8 Jason Tibbitts 2006-01-18 09:22:46 EST
I see that the fixed spec file is already checked into CVS; if you like, I can
(try to) request a build.

Did you make tag on te FC-4 branch yet?
Comment 9 Nicolas Mailhot 2006-01-18 09:49:45 EST
My current plague build queue is :
dejavu in FC-4 & FC-3
lzop in devel
and there were some perl-Convert-UUlib changes but I think I managed to push
them before plague stopped responding

All is in CVS, thank you for volunteering!
Comment 10 Jason Tibbitts 2006-01-18 10:05:41 EST
I requested all of the builds and they all made it into the buildsys, but it
seems to have died before actually completing any of the builds.

Oh, well.  I'll keep checking throughout the day.
Comment 11 Nicolas Mailhot 2006-01-18 10:11:57 EST
Now you understand why the CVS part is done but not the actual building :(
Comment 12 Jason Tibbitts 2006-01-18 13:54:06 EST
The dejavu-font packages were actually built after about an hour, but of course
they still need to be signed.  Since the queue is 2.5 days long I don't know
when that will happen.

The lzop package is stuck on x86_64; the other architectures built OK.

You did get a build of perl-Convert-UUlib out but of course it's in the
need_sign queue as well.
Comment 13 Nicolas Mailhot 2006-01-18 14:00:25 EST
Thanks for pushing this
1 hour for a simple package like dejavu! The buildsys is deeply sick
Comment 14 Jason Tibbitts 2006-01-18 16:26:35 EST
The FC-3 and FC-4 packages have been signed and pushed.

Note You need to log in before you can comment on or make changes to this bug.