Bug 178147 - pirut crashed: global name 'pango' is not defined
pirut crashed: global name 'pango' is not defined
Status: CLOSED DUPLICATE of bug 177973
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-01-17 20:32 EST by Ricky Ng-Adam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-18 12:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ricky Ng-Adam 2006-01-17 20:32:36 EST
Description of problem:

after or during depencies resolution

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. select package
2. try to install
Actual results:


Expected results:

no crash

Additional info:

Component: Software Manager
Summary: TBb4cd5369 __init__.py:410:depDetails:NameError: global name 'pango' is
not defined

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 298, in _apply
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 536, in
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 410, in depDetails
    tag.set_property('weight', pango.WEIGHT_BOLD)
NameError: global name 'pango' is not defined

Local variables in innermost frame:
mainwin: <gtk.Window object (GtkWindow) at 0xb74bdd9c>
self: <__main__.PackageManager object at 0xb79d780c>
b: <gtk.TextBuffer object (GtkTextBuffer) at 0xbcaffcc>
tag: <gtk.TextTag object (GtkTextTag) at 0xbcafeb4>
d: <pirut.DetailsDialog.PirutDetailsDialog instance at 0xb57ca02c>
Comment 1 Jeremy Katz 2006-01-18 12:27:47 EST

*** This bug has been marked as a duplicate of 177973 ***

Note You need to log in before you can comment on or make changes to this bug.