Bug 178155 - evolution requires gnome-pilot, which it shouldn't need to.
evolution requires gnome-pilot, which it shouldn't need to.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: FutureFeature
: 187999 222109 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 22:12 EST by Naoki
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 10:26:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to evolution.spec to split pilot conduits into evolution-pilot package (2.21 KB, patch)
2006-01-18 02:26 EST, Ian Burrell
no flags Details | Diff
Patch to evolution.spec to split pilot conduits into evolution-pilot subpackage (2.98 KB, patch)
2006-06-29 03:07 EDT, Ian Burrell
no flags Details | Diff

  None (edit)
Description Naoki 2006-01-17 22:12:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5

Description of problem:
Can we remove the dependency between evo and gnome-pilot.  For those who don't have palm pilots.

evolution-2.5.4-6.i386.rpm :
<snip>
gnome-pilot >= 2.0.13
<snip>

Version-Release number of selected component (if applicable):
evolution-2.5.4-6, gnome-pilot >= 2.0.13

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:

Comment from Ian :

It would be possible to split out the pilot conduits into a
subpackage.  Only the conduits in /usr/lib64/evolution/2.6/conduits
and /usr/lib64/gnome-pilot/conduits depend on gnome-pilot and
pilot-link.
Comment 1 Ian Burrell 2006-01-18 02:26:25 EST
Created attachment 123359 [details]
patch to evolution.spec to split pilot conduits into evolution-pilot package
Comment 2 Ian Burrell 2006-06-29 03:07:41 EDT
Created attachment 131718 [details]
Patch to evolution.spec to split pilot conduits into evolution-pilot subpackage

I updated my patch to split the pilot conduits into a subpackage.  This will
help with evolution depending on gnome-pilot and pilot-link.
Comment 3 Matthew Barnes 2006-11-07 15:56:03 EST
*** Bug 187999 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Barnes 2007-10-02 15:07:14 EDT
I'll try to get to this for Fedora 9.  Would be good to split the gnome-pilot
stuff out.  Thanks for the patch!
Comment 5 Matthew Barnes 2007-10-05 18:01:46 EDT
*** Bug 222109 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Barnes 2007-10-30 13:27:58 EDT
I'm attempting this in evolution-2.21.1-2.fc9 but I don't have the means to test
it beyond verifying that it builds properly.  Feedback would be appreciated.

I named the subpackage "evolution-conduits".
Comment 7 Matthew Barnes 2007-11-08 10:26:45 EST
Closing this until I hear any complaints.

Note You need to log in before you can comment on or make changes to this bug.