Bug 178187 - FC5T2 most gnome packages failed after yum update
FC5T2 most gnome packages failed after yum update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 09:02 EST by mokkarkay
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 06:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot of my Gnome Desktop with errors (79.35 KB, image/gif)
2006-01-18 09:06 EST, mokkarkay
no flags Details

  None (edit)
Description mokkarkay 2006-01-18 09:02:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
After a fresh install (choosing default option in all case) of FC5 T2, I ran "yum update". 
Things goes bad after the update finish, many icons from the top menu are missing.

After reboot, more error occured:

The Application "gnome-volume-manager" has quit unexpectedly.

I tried to start other application like terminal, same error occur:

The Application "gnome-terminal" has quit unexpectedly.

I ran yum update again to make sure I have completely updated, and it shows I've already finished all update.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make fresh install of FC5 T2, accepting all default options
2. Run "yum update"
3. Reboot the system, things in gnome goes wrong.
  

Actual Results:  1. many icon from the "start menu" missing.
2. can't start terminal, with error message:
The Application "gnome-terminal" has quit unexpectedly.

3. when startup, the followign message occur:
The Application "gnome-volume-manager" has quit unexpectedly.

Expected Results:  Nothing should occur if things goes normally

Additional info:
Comment 1 mokkarkay 2006-01-18 09:06:17 EST
Created attachment 123374 [details]
Screen Shot of my Gnome Desktop with errors
Comment 2 Joshua M. Thompson 2006-01-19 12:17:38 EST
I can confirm this on my system, though I went FC4 -> FC5t2 -> today's yum
update. In addition to none of the panel applets working anymore evolution also
stopped working; it only brings up an empty window now with the Send/Receive
button. Starting it from a shell reveals these errors:

(evolution:4175): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Mail_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-mail.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-mail.so: cannot open shared
object file: No such file or directory'


(evolution:4175): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Calendar_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


(evolution:4175): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Tasks_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


(evolution:4175): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Memos_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


(evolution:4175): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Addressbook_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-addressbook.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-addressbook.so: cannot open
shared object file: No such file or directory'

The files are indeed there, assuming $(LIB) == 'lib'
Comment 3 Rahul Sundaram 2006-02-20 06:05:39 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 mokkarkay 2006-02-24 09:27:09 EST
Confirm it's fixed in FC5 test3
Comment 5 Rahul Sundaram 2006-03-05 06:04:07 EST

Closing as per last comment

Note You need to log in before you can comment on or make changes to this bug.