This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 178257 - Add features to pup & pirut
Add features to pup & pirut
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 16:20 EST by Don Springall
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6 updates
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 11:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Springall 2006-01-18 16:20:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Features requested:

1) If you want to download just one package out of those available you get to manually uncheck them all in pup. Please add an unselect all button.

2) Should be able to select which plugins you want to use. (best mirror etc)

3) Add selection of repo's to use as in pirut

4) Add more gracefull error handling to pup & pirut. Exit with a message instead of just exiting. (more of a problem in pirut than pup, pup seems to do a traceback more often)

5) After asking for root password there is no indication program is still running. Nothing in system tray or desktop progress bar until repo data has loaded. This can be quite a delay in pirut. And if pirut exits, only way to tell is by checking running process in system monitor.




Version-Release number of selected component (if applicable):
pirut-0.9.4-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Jeremy Katz 2006-01-24 18:47:23 EST
*sigh*  Multiple in one things like this are extremely hard to deal with in
bugzilla as I can't easily track the different pieces.

1 -- What's the use case convincing for doing an unselect all?  It's not like
updates are (generally) superfluous.  Also, for the not-rawhide case, the number
of updates shouldn't be nearly as overwhelming

2 -- I'm don't feel strongly one way or another about adding a plugin
enabler/disabler to the pirut interface.  So mostly a question of time or
someone submitting a patch.  One thing that's difficult is that changing the
plugin set up will require a reload of rrepository info

3 -- Why would you want to configure repositories specifically in pup?  For the
record, I originally had it there, but disabled it because it was seen as a bit
of clutter that just isn't generally needed -- if you're installing software
from a repository, why wouldn't you want updates.  And likewise for the disabled
case

4 -- Both should give a traceback dialog in the case of an error now.  If you
hit errors which aren't caught, please file specific bugs

5 -- Back to having the feedback on startup that used to be in pup and I just
(temporarily) lost in porting over to the pirut framework
Comment 3 Jesse 2007-03-21 16:40:42 EDT
1 -- I would like to second the request to have a "unselect all" button or
the ability to highlight a group of entries using SHIFT and the mouse.
I just installed Fedora Core 6 and there were over 330 updates. It would have
been helpful to be able to select a bunch of updates and leave the rest.

I ended up using the command line to update groups instead.

It would also be nice if when I make Pup ful screen if the panes
(description and package list) would scale.
Comment 4 Jeremy Katz 2007-03-23 11:46:12 EDT
(In reply to comment #3)
> 1 -- I would like to second the request to have a "unselect all" button or
> the ability to highlight a group of entries using SHIFT and the mouse.
> I just installed Fedora Core 6 and there were over 330 updates. It would have
> been helpful to be able to select a bunch of updates and leave the rest.

This can be done with the version in FC6 updates.

Generally, the things here are handled, so going to close this one out.

Note You need to log in before you can comment on or make changes to this bug.