Bug 178272 - install partition warning for PPC PReP Boot partition size
install partition warning for PPC PReP Boot partition size
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 178273 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 18:30 EST by Patrick Mansfield
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 16:01:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Mansfield 2006-01-18 18:30:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
During text install of fc devel (dated jan 16 2006) to an IBM JS20 (ppc64
blade), after selecting the default parition, I am getting the following
warning:

    The following warnings exist with
    your requested partition scheme.

    Your PPC PReP Boot partition is less
    than 2 megabytes which is lower than
    recommended for a normal Fedora Core
    install.

    Would you like to continue with your
    requested partitioning scheme?

There were partitions on the device (hda) before I started the install (once, RHEL4 or such, and this time, I am installing on top of FC devel).

The system booted OK, but it should not complain about its default partition layout :-(

During VNC install of this same image, I got a black screen with black
text for (I assume) this same warning. I ran a text install this time to
see if anything was actually being displayed.

The partition information is displayed as:

      Device        Start    End     Size       Type     Mount Point
 VG VolGroup00                       38016M  VolGroup
 LV LogVol00                         36032M  ext3        /
 LV LogVol01                          1984M  swap
 /dev/hda
   hda1                  1       1       0M  PPC PReP B
   Free space            1       1       7M  Free space
   hda2                  2      13      94M  ext3        /boot
   hda3                 14    4864   38052M  physical v


Version-Release number of selected component (if applicable):
anaconda-10.91.4-1

How reproducible:
Always

Steps to Reproduce:
1. Install to ppc64 system.
2. Use default partitioning.
3. Make money
  

Actual Results:  Got a warning

Expected Results:  No warning expected

Additional info:
Comment 1 Patrick Mansfield 2006-01-18 20:28:31 EST
I just ran a VNC install and did not hit the warning.

[my text install hung twice, this is a JS20 with Serial Over Lan ... SOL].

Comment 2 Paul Nasrat 2006-01-19 15:34:50 EST
*** Bug 178273 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-01-28 00:20:49 EST
What was the previous install?  We try to create a 4 meg partition, but if
there's a pre-existing PReP boot partition, then it won't be formatted by
default (as doing so tended to cause problems for other testers at ibm ;-)
Comment 4 Patrick Mansfield 2006-01-31 16:01:27 EST
Yes, the previous install had partitioned it to that size.

Deleting all partitions and installing, there is no warning and prep boot size
is fine.

Partitioning with "Remove all partitions on selected drives and create default
layout" worked fine (even with pre-existing too small PReP partition) with no
wanring.

Installing/partitioning with "Remove linux partitions on selected drives and
create default layout" on top of a drive with too small PReP partitoin gives a
warning.

So, just a bit confusing to me that the PReP Boot partition was not resized for
this last case.

I am closing the bug.

Note You need to log in before you can comment on or make changes to this bug.