Bug 178292 - [calendar] unable to commit native characters in list view with scim
[calendar] unable to commit native characters in list view with scim
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 01:28 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-2.7.3-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 05:56:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-01-19 01:28:55 EST
Description of problem:
When trying to commit characters from pre-edit buffer to the application, the
result is blank.

Version-Release number of selected component (if applicable):
evolution-2.5.4-2
evolution-data-server-1.5.4-2
scim-1.4.2-9

How reproducible:
Always

Steps to Reproduce:
1.in any of the CJKI locale, start evolution-> calendar (eg ja_JP.UTF-8)
2.select list view
3.click any slot under the summary column
4.activate SCIM with Ctrl-SPACE (eg. ja IME, Anthy)
5.enter 'aka enter'
  
Actual results:
commits nothing

Expected results:
native character commit

Additional info:
Comment 1 Lawrence Lim 2006-02-12 20:47:33 EST
Actually input's preedit buffer is not showing in List View as well.
Comment 2 Rahul Sundaram 2006-02-20 05:39:34 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Mayank Jain 2006-05-19 11:15:06 EDT
Seems to be fixed by upstream in evo 2.7.2-1 (cvs release).
Please check

Thanks,
Mayank
Comment 6 A S Alam 2006-05-24 06:08:26 EDT
Not working, bug is still exist

Tested under following envirnment:
LANG=ja_JP.UTF-8

evolution-sharp-0.11.1-1
evolution-data-server-devel-1.7.2-1
evolution-data-server-1.7.2-1
evolution-2.7.2.1-1
evolution-webcal-2.7.1-1
Comment 7 Satyabrata Maitra 2006-06-20 08:40:50 EDT
Test Result : Character is commiting when Hit ENTER key after putting the
character, otherwise not. And if Not Hit Enter key, and click outside and again
click into the listview box, the character entered previously is showing
autometically.

Tested with Packages and versions :

evolution-2.7.3-2
evolution-data-server-1.7.3-2
evolution-sharp-0.11.1-1
evolution-webcal-2.7.1-4

Tested on O.S. : Fedora Core Release 5.89 (Rawhide) i386.

Comment 8 Mayank Jain 2006-06-21 02:24:45 EDT
Hi Satya,

I think what you have mentioned can be another anomaly.

IMO, this bug is fixed in latest codebase.

Thanks,
Mayank
Comment 10 A S Alam 2006-07-10 05:56:31 EDT
It is working fine and bug is fixed, tested with

evolution-2.7.3-9



Note You need to log in before you can comment on or make changes to this bug.