Bug 178297 - bad: GFS + ACL incorrect?
bad: GFS + ACL incorrect?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: GFS (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan O'Hara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 03:20 EST by Andrey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 15:27:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey 2006-01-19 03:20:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
service ccsd start  
service cman start  
service fenced start  
service gfs start  
service rgmanager start  
  
mount | grep gfs  
/dev/sdb1 on /media/vtrak type gfs (rw,acl)  
  
yes, example:  
  
cd /media/vtrak  
mkdir testdir  
  
setfacl -d -m u:afletdinov:rwx testdir <- default acl OK 
setfacl -m u:afletdinov:rwx testdir  
setfacl: testdir: No data available  <- ERROR 
  
getfacl testdir 
user::rwx 
group::r-x 
other::r-x 
default:user::rwx 
default:user:afletdinov:rwx 
default:group::r-x 
default:mask::rwx 
default:other::r-x 
 

Version-Release number of selected component (if applicable):
GFS-6.1.0-3

How reproducible:
Always

Steps to Reproduce:
1. setfacl -m u:afletdinov:rwx testdir 
 

Additional info:
Comment 1 Jonathan Earl Brassow 2006-01-19 14:33:04 EST
Did you mount with the acl option?

mount -t gfs <block dev> <mnt_point> -o acl

Remember to do this for all your machines.  (May wish to add it to /etc/fstab)
Comment 2 Andrey 2006-01-19 19:16:20 EST
mount | grep gfs   
/dev/sdb1 on /media/vtrak type gfs (rw,acl)   
Comment 3 Andrey 2006-02-09 04:43:19 EST
This bug can be reproduced only with software iscsi (open-iscsi-0.5.454). With 
hardware iscsi (qlogic 4010c) there is no problems with ACL in GFS. 
Comment 4 Andrey 2006-02-14 22:48:12 EST
GFS with default ACL on new folder is not applied ?! 
 
I use version: 
kernel-2.6.9-22.0.2.ELsmp 
GFS-kernel-smp-2.6.9-45.0.2 
GFS-6.1.3-0 
 
I use GFW with ACL: 
/dev/sda5 on /home type gfs (rw,noatime,acl) 
 
/dev/sda it hardware ISCSI QLogiq 4010C. 
 
examples: 
 
# cd /home 
# mkdir test_acl 
 
If now to apply default ACL on folder we receive a errors. 
 
# setfacl -d -m g:dc_local:rwx test_acl/ 
setfacl: test_acl: Operation not permitted 
 
 
After that the same without errors!? 
# setfacl -d -m g:dc_local:rwx test_acl/ 
# getfacl test_acl 
 
# file: test_acl 
# owner: root 
# group: root 
user::rwx 
group::r-x 
other::r-x 
default:user::rwx 
default:group::r-x 
default:group:dc_local:rwx 
default:mask::rwx 
default:other::r-x 
 
Comment 5 Andrey 2006-02-15 04:33:17 EST
I have checked up as and on a local SCSI disk, effect same. 
Comment 7 Ryan O'Hara 2006-11-13 15:27:20 EST
I attempted to recreate this problem on RHEL4 and was unsuccessful. All of my
setfacl and getfacl commands worked as expected. No errors. I'm closing this
since it appears to work properly.




Note You need to log in before you can comment on or make changes to this bug.