Bug 178307 - SiS sound dosn't work with SiS chipset 965L
SiS sound dosn't work with SiS chipset 965L
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2006-01-19 05:18 EST by Christian
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-23 10:06:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christian 2006-01-19 05:18:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Machine: F-S Esprimo p5600 Dual AMD x86_64. Same problem on almost every singel distribution I've tried and over two different AMD CPU's. The only way to get partial sound support, is by enabling OSS and use the front installed jack. Jack in the back doesn't work in OSS either. 

A very disturbing observation is that I think this issue has been present for a long time, and never been fixed because the bugs become closed as the version number changes. So I've tried to upgrade the severity to see if somebody can give this issue the needed priority to get it fixed.

Fedora Core 5 has managed to solve several problems from FC4 and others. In addition to providing several of the /dev entries :

from ls dev/ :
snd/seq  snd/timer

the lsmod output also seems to make sense :

[root@hyll2 ~]# lsmod
Module                  Size  Used by
snd_intel8x0           68329  0 
snd_ac97_codec        135961  1 snd_intel8x0
snd_ac97_bus           35905  1 snd_ac97_codec
snd_seq_dummy          37189  0 
snd_seq_oss            66241  0 
snd_seq_midi_event     41153  1 snd_seq_oss
snd_seq                89953  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         42961  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            85585  0 
snd_mixer_oss          51009  1 snd_pcm_oss
snd_pcm               126537  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              59593  2 snd_seq,snd_pcm
snd                    97257  9 snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              44257  1 snd
snd_page_alloc         44625  2 snd_intel8x0,snd_pcm

But no sound.
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 761/M761 Host (rev 01)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS965 [MuTIOL Media IO] (rev 48)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)

Error message from dmesg related to sound is :
codec_ready: codec is not ready [0x340000]
Intel ICH: probe of 0000:00:02.7 failed with error -5

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual Results:  no sound

Expected Results:  sound

Additional info:
Comment 2 Martin Stransky 2006-01-23 10:06:17 EST
ALSA project is the right place for fixing this bug.

Note You need to log in before you can comment on or make changes to this bug.