Bug 178323 - kdelibs: /etc/profile.d/kde.(csh|sh) additions
kdelibs: /etc/profile.d/kde.(csh|sh) additions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature, Reopened
: 178616 (view as bug list)
Depends On:
Blocks: 196013
  Show dependency treegraph
 
Reported: 2006-01-19 09:23 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 02:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample kde.sh (1.18 KB, text/plain)
2006-01-19 09:23 EST, Rex Dieter
no flags Details
sample kde.csh (1.06 KB, text/plain)
2006-01-19 09:24 EST, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2006-01-19 09:23:23 EST
Per http://kde.ground.cz/tiki-index.php?page=Environment+Variables, items to 
consider adding: 
KDE_IS_PRELINKED  (for sure!) 
 
optional, but disabled by default items: 
KDE_FORK_SLAVES 
KDE_NO_IPV6 
GLIBCXX_FORCE_NEW
Comment 1 Rex Dieter 2006-01-19 09:23:23 EST
Created attachment 123438 [details]
sample kde.sh
Comment 2 Rex Dieter 2006-01-19 09:24:25 EST
Created attachment 123439 [details]
sample kde.csh
Comment 3 Ngo Than 2006-05-16 08:38:21 EDT
i have already added some usefull KDE envoremnts for FC in /etc/kde/env/env.sh
(kdebase). Thanks for your report.
Comment 4 Ngo Than 2006-05-16 08:42:08 EDT
*** Bug 178616 has been marked as a duplicate of this bug. ***
Comment 5 Rex Dieter 2006-05-16 08:45:12 EDT
IMO, it would be better to put this in /etc/profile.d, else KDE apps launched
from outside of KDE environment (from Gnome, for example) won't benefit.
Comment 6 Ngo Than 2006-05-16 09:00:43 EDT
i forgot the user trying to start outside of KDE environment ;-)
sure, it should go into kdelibs. Thanks
Comment 7 Laurent Rineau 2006-06-20 05:51:22 EDT
The resolution of this bug, in kdelibs-3.5.3-0.2 (on FC-5 at least), has 
broken /etc/zprofile (for zsh users).

It seems that the syntax used in /etc/profile.d/kde.sh is not understandable 
by the Z shell. My login shell is /bin/zsh, and each launched login shell 
complains with:
 /etc/profile.d/kde.sh:4: = not found

Here is the patch:
--- /tmp/kde.sh	2006-06-20 11:57:00.000000000 +0200
+++ /tmp/kde.sh4454S5r	2006-06-20 11:57:00.000000000 +0200
@@ -1,7 +1,7 @@
 # When/if using prelinking, avoids (some) use of kdeinit
 if [ -f /etc/sysconfig/prelink ] ; then
    source /etc/sysconfig/prelink
-   if [ "$PRELINKING" == yes ] ; then
+   if [ "$PRELINKING" = yes ] ; then
       [ -z "$KDE_IS_PRELINKED" ] && KDE_IS_PRELINKED=1 && export 
KDE_IS_PRELINKED
    fi
 fi

Somebody suffers from an overdose of C++. ;-)

What is more, /etc/profile.d/kde.sh is not a config file. rpm --verify 
complains if I modify it. I think this should be fixed (but it should be 
another bug report).
Comment 8 Rex Dieter 2006-06-20 07:27:41 EDT
> What is more, /etc/profile.d/kde.sh is not a config file. rpm --verify 
> complains if I modify it. I think this should be fixed (but it should be 
> another bug report).

IMO, it *should* be marked %config, else local modifications will get lost
when/if kdelibs gets upgraded.  You wouldn't want that, would you?
Comment 9 Rex Dieter 2006-06-20 07:30:56 EDT
Personally, I also think the the source'ing of /etc/sysconfig/prelink is
dubious, because it polutes the users' environment space.
Comment 10 Laurent Rineau 2006-06-20 08:06:53 EDT
(In reply to comment #8)
> > What is more, /etc/profile.d/kde.sh is not a config file. rpm --verify 
> > complains if I modify it. I think this should be fixed (but it should be 
> > another bug report).
> 
> IMO, it *should* be marked %config, else local modifications will get lost
> when/if kdelibs gets upgraded.  You wouldn't want that, would you?

I fully agree. I eventually have filled bug #196013, to address this issue. It 
will avoid the polution of the current bug.
Comment 11 Ngo Than 2006-06-24 02:50:28 EDT
it's now fixed in kdelibs-3.5.3-5. Thanks for your 
report.
Comment 12 Laurent Rineau 2006-06-29 10:09:02 EDT
Will kdelibs-3.5.3-5 be pushed in FC-4 and FC-5?
I have checked in CVS repository, and it seems that the bug is not corrected 
in FC-4 and FC-5 branches.

Note You need to log in before you can comment on or make changes to this bug.