Bug 178326 - kdebase: create/own {/usr,/etc/kde}/{env,shutdown}
Summary: kdebase: create/own {/usr,/etc/kde}/{env,shutdown}
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: EasyFix, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-19 14:50 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 19:19:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2006-01-19 14:50:37 UTC
As referenced in /usr/bin/startkde, kdebase should create/own the directories: 
/usr/env 
/usr/shutdown 
that contain kde-specific source'd startup and shutdown scripts, respectively.

Comment 1 Ngo Than 2006-02-15 17:47:52 UTC
I have added both env and shutdown directories under /etc/kde/ 
in next kdebase rebuild. Of course, the startkde script will be adjusted to 
look the scripts there. 
 
 

Comment 2 Rex Dieter 2006-02-15 18:17:45 UTC
*** Bug 175744 has been marked as a duplicate of this bug. ***

Comment 3 Rex Dieter 2006-02-15 18:36:17 UTC
In order to stay compatible with upstream, IMO, it would be safest to modify
startkde to look in *both* /usr and /etc/kde for env/ and shutdown/

Comment 4 Rex Dieter 2006-04-11 14:57:41 UTC
Ngo, can you respond to my comment #3?  Seen a few users get confused because
kde docs tell them to use /usr/env and /usr/shutdown, and that doesn't work on
FC-5.  (-:

Comment 5 Ngo Than 2006-04-12 12:49:09 UTC
yes, it should still look in /usr/env and /usr/shutdown to stay compatible with
upstream. It's now fixed in CVS. For FC5, i will fix it soon.

Thanks for your report.


Comment 6 Rex Dieter 2006-06-22 17:17:42 UTC
Just checked cvs, and the only dir ownership I see is in -devel branch, and
there it's only /etc/kde/env/ (missing /etc/kde/shutdown/).  

The patch (to use /etc/kde/{env,shutdown) instead of /usr/{env,shutdown} )
appears to be applied to all branches (FC-4, FC-5, devel).

While you're at it, I'd recommend creating/owning (empty) /usr/env,
/usr/shutdown dirs as well, but that's your call.

Comment 7 Rex Dieter 2006-08-22 12:33:28 UTC
Ping, EasyFix here.

Comment 8 Rex Dieter 2007-05-15 19:19:22 UTC
* Tue May 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.6-9
- create/own {/usr,/etc/kde}/{env,shutdown} (#178326)



Note You need to log in before you can comment on or make changes to this bug.