Bug 178340 - .1861 Oops enabling eth0/eth1?
.1861 Oops enabling eth0/eth1?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 11:25 EST by Tom London
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 00:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-01-19 11:25:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Running latest rawhide, targeted/enforcing.

Booting .1861 appears to hang enabling eth0. I can see the LED on my router flashing a few times, and it looks like the interface is turned off and on once or twice.

Booting with 'rhgb quiet' removed shows the hang before the 'done/OK' for eth0, and if I wait about 60 seconds or so, I get an Oops.

Of course, the message scrolls off the top of the screen, but here is what I can 'cut/paste' to paper: 

EIP is ipw_irq_tasklet
process ifup
filp_dtor     cache_free_debugcheck
__rcu_process_callbacks
tasklet_action
dosoftirq
do_IRQ
common_interrupt

After the 120 second countdown:
<0> Kernel panic - not syncing
panic+0x3e
die
do_page_fault
ipw_irq_tasklet
cache_free_debugcheck
__rcu_process_callbacks
__do_soft_irq
=======
do_IRQ

.1860 boots fine.  What else can I give to help here....

tom




Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1861_FC5

How reproducible:
Always

Steps to Reproduce:
1. boot .1861
2.
3.
  

Additional info:
Comment 1 Tom London 2006-01-20 10:13:38 EST
Looks like I can reproduce this on my home network (interestingly, not on my
'work' network.)

Booting with vga=791, and manually writing down the contents of the screen, I
get the info below.

.1862 appears to boot reliably.
   tom

---------------------------------------------

Unable to handle kernel paging request 6b6b6b6b6b
Oops 0000[#1]
last sysfile: /devices/system/cpu/cpu0/cpufreq/scaling_setspeed

CPU 0
EIP: 0060[<f8ca656d] not tainted VLI
EFLAGS 00010097 (2.6.15-1-1861_FC5)
EIP is at ipw_irq_tasklet+0x8f/0xf97 (ipw2200)
eax: f70678b8 ebx: 02 ecx: 01b edx: f7296548
esi: 6b6b6b6b6 edi 0a ebp f71ac720 esp: c03d7f88
ds 07b es 07b ss 068

Process dhclient_script (pid 1932 threadinfo=c03d7000 task=c1dd37f0)
call trace:
filp_dtor                   cache_free_debugcheck
__rcu_process_callbacks     __rcu_process_callbacks
tasklet_action              __do_softirq
do_sortirq                  ====================
do_IRQ
common_interrupt            kmap_atomic
__handle_mm_fault           do_page_fault
do_page_fault               error_code

Comment 2 Tom London 2006-01-20 10:27:41 EST
.1863 also boots fine.

Can this be attributed to broken e1000 code in .1861? 

close?
Comment 3 Dave Jones 2006-01-24 00:22:39 EST
ok.  keep an eye for trouble, and reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.