Bug 178359 - hcid won't start due to selinux problem
hcid won't start due to selinux problem
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 15:00 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 04:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2006-01-19 15:00:03 EST
Description of problem:
As of 1/19/2006 the hcid daemon won't start unless the enforcing=0.


Version-Release number of selected component (if applicable):
bluez-utils-2.22-2.1
selinux-policy-2.1.13-1
selinux-policy-targeted-2.1.13-1



How reproducible:
always


Steps to Reproduce:
1.
2.
3.
  
Actual results:
hcid doesn't start and I cannot use bluetooth devices

Expected results:
hcid starts


Additional info:
Comment 1 Brian G. Anderson 2006-02-03 07:48:04 EST
This still occurs with:
selinux-policy-2.2.9-2
selinux-policy-targeted-2.2.9-2
Comment 2 Brian G. Anderson 2006-02-03 08:01:00 EST
audit2why tells me:
type=AVC msg=audit(1138959953.541:158): avc:  denied  { read } for  pid=3448
comm="hid2hci" name="001" dev=tmpfs ino=3564
scontext=user_u:system_r:bluetooth_t:s0 tcontext=system_u:object_r:device_t:s0
tclass=chr_file



audit2allow tells me:
allow bluetooth_t device_t:chr_file read;
Comment 3 illtud 2006-03-24 10:13:40 EST
Me too. hcid bombs out with:

Mar 24 15:15:28 localhost hcid[18217]: Bluetooth HCI daemon
Mar 24 15:15:28 localhost hcid[18217]: Can't get system message bus name:
Connection ":1.16" is not allowed to own the service "org.bluez" due to SELinux
policyMar 24 15:15:28 localhost hcid[18217]: Unable to get on D-BUS
Comment 4 Guy Streeter 2006-03-28 15:01:58 EST
On released FC5, I get the same /var/log/messages entries about hcid as above,
but the only audit messages I see are about bluez-pin, not hcid.
Comment 5 David Woodhouse 2006-09-10 04:55:42 EDT
Please re-open and file against selinux-policy is this is still happening.

Note You need to log in before you can comment on or make changes to this bug.