Bug 178363 - yum showing traceback on update
yum showing traceback on update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 15:24 EST by Trever Adams
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 14:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2006-01-19 15:24:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Below is a traceback I am getting. I see it only one one of two systems (I haven't tried the other two yet). It appears to have to do with a proxy but the only proxy settings I have are on all the machines I believe and are done through the gnome proxy setting.

# yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
developmen: #########################                          1/2Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 480, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 947, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 70, in doRepoSetup
    yum.YumBase.doRepoSetup(self, thisrepo=thisrepo)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 249, in doRepoSetup
    repo.getRepoXML(text=repo)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 681, in getRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 625, in get
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 400, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 618, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 547, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 604, in retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 728, in __init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 820, in _do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 887, in _make_request
    fo = opener.open(req)
  File "/usr/lib/python2.4/urllib2.py", line 358, in open
    response = self._open(req, data)
  File "/usr/lib/python2.4/urllib2.py", line 376, in _open
    '_open', req)
  File "/usr/lib/python2.4/urllib2.py", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.4/urllib2.py", line 573, in <lambda>
    lambda r, proxy=url, type=type, meth=self.proxy_open: \
  File "/usr/lib/python2.4/urllib2.py", line 580, in proxy_open
    if '@' in host:
TypeError: iterable argument required


Version-Release number of selected component (if applicable):
yum-2.5.1-2

How reproducible:
Always

Steps to Reproduce:
1. unsure other than run yum
2.
3.
  

Additional info:
Comment 1 Jack Spaar 2006-01-20 14:45:55 EST
"Me too."  But even with no gnome proxy defined.

If all repos are disabled, the traceback looks like so:

$ yum list updates
Setting up repositories
No Repositories Available to Set Up
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 506, in doCommands
    ypl = self.returnPkgLists()
  File "/usr/share/yum-cli/cli.py", line 1168, in returnPkgLists
    ypl = self.doPackageLists(pkgnarrow=pkgnarrow)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 915, in
doPackageLists
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 70, in doRepoSetup
    yum.YumBase.doRepoSetup(self, thisrepo=thisrepo)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 257, in doRepoSetup
    self.repos.callback.progressbar(num, len(repos), repo.id)
UnboundLocalError: local variable 'repo' referenced before assignment

Additionally:
$ yum shell
Setting up Yum Shell
> help
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 438, in doShell
    yumshell.cmdloop()
  File "/usr/lib/python2.4/cmd.py", line 142, in cmdloop
    stop = self.onecmd(line)
  File "/usr/lib/python2.4/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/share/yum-cli/shell.py", line 92, in do_help
    msg = self.base.optparser.print_short_help()
AttributeError: YumOptionParser instance has no attribute 'print_short_help'
Comment 2 Trever Adams 2006-01-20 16:04:22 EST
If I change mine to direct connection to the Internet, no proxy, everything
works just fine.

Yours appears to be a different problem based on the traceback. Try doing a rpm
-V yum and rpm -V related packages (whichever they are).

Trever
Comment 3 Seth Vidal 2006-01-22 20:22:30 EST
comment 1: neither of those tracebacks have anything to do with the problem.

Your first traceback says you have no repos defined.
The second one is a bug in the shell that's been fixed.
Comment 4 Trever Adams 2006-01-23 14:09:10 EST
Ok, I have many repos defined. So, now I will turn back on gnome proxy (after
turning it off and having it work for several days).

# yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
developmen: #########################                          1/2Traceback
(most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 480, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 947, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 70, in doRepoSetup
    yum.YumBase.doRepoSetup(self, thisrepo=thisrepo)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 249, in doRepoSetup
    repo.getRepoXML(text=repo)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 681, in getRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 625, in get
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 400, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 618, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 547, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 604, in
retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 728, in
__init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 820, in
_do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 887, in
_make_request
    fo = opener.open(req)
  File "/usr/lib/python2.4/urllib2.py", line 358, in open
    response = self._open(req, data)
  File "/usr/lib/python2.4/urllib2.py", line 376, in _open
    '_open', req)
  File "/usr/lib/python2.4/urllib2.py", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.4/urllib2.py", line 573, in <lambda>
    lambda r, proxy=url, type=type, meth=self.proxy_open: \
  File "/usr/lib/python2.4/urllib2.py", line 580, in proxy_open
    if '@' in host:
TypeError: iterable argument required


Now turn it back off....

# yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-dev: ################################################## 2/2
extras-development        100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.2 MB    00:03
developmen: ################################################## 4286/4286
Added 4286 new packages, deleted 0 old in 37.85 seconds
primary.xml.gz            100% |=========================| 1.1 MB    00:03
extras-dev: ################################################## 3131/3131
Added 3131 new packages, deleted 0 old in 35.62 seconds
etc.

Of course you have to open new terminals AFTER the proxy changes for them to do
anything. Secondly, my proxy config has not changed in about 2 months (and that
was minimal, things still worked). Thirdly, firefox uses the same proxy and it
is still working.
Comment 5 Trever Adams 2006-01-26 15:54:42 EST
I now have to disable the gnome proxy settings on all machines that use yum.
Without proxy settings, everything works fine, with them, it doesn't.

My proxy configuration is almost perfectly the standard configuration. I setup
an ACL for my network (based on one that was in the file) and everything else
works. I bumped a few of the cache megabyte numbers (up not down). Yum barfs.
Everything else works (including Firefox on Windows and Linux) and most are
setup to use the proxy (or when gnome proxy info has my proxy).
Comment 6 Jeremy Katz 2006-04-19 16:34:53 EDT
Is this fixed with yum-2.6.0-3 in the devel tree?
Comment 7 Trever Adams 2006-04-20 14:30:46 EDT
No, it appears to have been fixed. I am sorry I didn't report this sooner. I
just turned off the proxy and forgot about it.

Note You need to log in before you can comment on or make changes to this bug.