Bug 178371 - Anaconda keeps using US keyboard during installation
Anaconda keeps using US keyboard during installation
Status: CLOSED DUPLICATE of bug 178030
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 16:07 EST by Jean Francois Martinez
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 16:54:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2006-01-19 16:07:25 EST
Description of problem: Anaconda uses US keyboard during installation => big
surprise first time you boot since the root password doesn't match


Version-Release number of selected component (if applicable):


How reproducible:  Always


Steps to Reproduce:
1.  Do an installation using a French keyboard
2.  When asked for root password use one including A,Q,Zo or Ws
3.  Reboot
  
Actual results:  After reboot my box was using French keyboard but I was unable
to login as root.  I managed to connect by typing Q for an A, A for a Q, W for Z
and Z for W.  Problem is that the Anaconda graphic installer had remained on US
so the password I typed blind had shifted letters. 


Expected results:  My password matching what I typed at install time


Additional info:  I noticed that during installation the text console using
French keybord.  Also this is arecurring problem: time and again the
RedHat/Fedora betas have had this keybboard related bug.  There is also a bug in
teh genral design: the installer doesn't ask the user for atry of the keyboard
in case either the user or the installer got it wrong.  So if you use DHCP (I
do) and content with the predefined mount points the only thing you type is
the root password and this you do it blind.  So bugs or usermsitakes will go
undetected until you reboot
Comment 1 Chris Lumens 2006-01-19 16:54:46 EST

*** This bug has been marked as a duplicate of 178030 ***

Note You need to log in before you can comment on or make changes to this bug.