Bug 178374 - Evolution (and panel apps) build problem
Summary: Evolution (and panel apps) build problem
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-19 21:26 UTC by Luke Hutchison
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-01 02:24:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luke Hutchison 2006-01-19 21:26:44 UTC
I just updated to the latest FC5-devel RPMs, including:

# rpm -q evolution gnome-panel
evolution-2.5.4-9
gnome-panel-2.13.5-1

Both Evolution and the panel apps exhibit an error starting up, because the
directory "/usr/$(LIB)/..." cannot be found:

# evolution

(evolution:3004): Gtk-WARNING **: Theme directory 16x16/status16x16/stock/chart
of theme gnome has no size field


(evolution:3004): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Calendar_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


(evolution:3004): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Memos_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


(evolution:3004): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Addressbook_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-addressbook.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-addressbook.so: cannot open
shared object file: No such file or directory'


(evolution:3004): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Mail_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-mail.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-mail.so: cannot open shared
object file: No such file or directory'


(evolution:3004): evolution-shell-WARNING **: Cannot activate
'OAFIID:GNOME_Evolution_Tasks_Component:2.6': g_module_open of
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so' failed with
`/usr/$(LIB)/evolution/2.6/components/libevolution-calendar.so: cannot open
shared object file: No such file or directory'


evolution-mail-ERROR **: file mail-config.c: line 708
(mail_config_get_accounts): assertion failed: (config != NULL)
aborting...

(gnome_segv:3005): Gtk-WARNING **: Theme directory 16x16/status16x16/stock/chart
of theme gnome has no size field



Apparently the variable $(LIB) is not defined and/or not being expanded by
g_module_open.

The following fixes the problem, although it is a big ugly hack:

# ln -s /usr/lib /usr/\$\(LIB\)

Comment 1 Luke Hutchison 2006-01-19 21:27:29 UTC
Sorry, the stuff after the 3 blank lines above are my additional comments, not
part of the output from Evolution.


Comment 2 Rahul Sundaram 2006-02-20 11:32:05 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 4 Matthew Barnes 2006-12-31 02:36:54 UTC
Is this problem still present in Fedora Core 6?  I don't see any of these
warnings myself.

Comment 5 Luke Hutchison 2007-01-01 02:24:45 UTC
I haven't seen this recently.  Closing, thanks!


Note You need to log in before you can comment on or make changes to this bug.