Bug 17839 - SWAT wont run
Summary: SWAT wont run
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
: 18152 18574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-25 23:43 UTC by Steven Taylor
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-01 22:52:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven Taylor 2000-09-25 23:43:39 UTC
by default SWAT is disabled, but even after enabling it, it still wont run,
i get broken pipe.
Here is what my current /etc/xinetd.d/swat looks like, note i changed
disable to no.

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
#              to configure your Samba server. To use SWAT, \
#              connect to port 901 with your favorite web browser.
service swat
{
        disable = no
        port    = 901
        socket_type     = stream
        wait    = no
        only_from = localhost
        user    = root
        server  = /usr/sbin/swat
        log_on_failure  += USERID
}

Comment 1 Dan Browning 2000-09-30 22:54:25 UTC
For me, I had to remove the "only_from = localhost" and "disabled = yes" lines 
before it would work.  (See recent posts by Dan Browning on redhat-
list@redhat.com).

Comment 2 Alan Cox 2000-10-01 22:51:58 UTC
He has disabled = no which is fine. The only_from = localhost means using
127.0.0.1 as the
address if I remember rightly. Anyway does removing that only_from or using
127.0.0.1 work ?


Comment 3 Bill Nottingham 2000-10-02 21:51:02 UTC
Yup. You first must enable it, either with chkconfig
or ntsysv. It is configured to only listen on localhost
as a security measure.


Comment 4 Bill Nottingham 2000-10-03 14:04:55 UTC
*** Bug 18152 has been marked as a duplicate of this bug. ***

Comment 5 Phil Venton 2000-10-09 08:38:23 UTC
I have found this to be caused by an odd /etc/hosts file after a fresh install. 
If you change the default contents of /etc/hosts from, eg:

127.0.0.1 localhost.localdomain localhost foo.bar.net foo

to the (as I understand) more correct:

127.0.0.1 localhost.localdomain localhost
192.168.0.1 foo.bar.net foo

then (assuming you've enabled it with "disabled=no") it will work fine.  I'm
guessing xinetd tries to resolve 127.0.0.1 into a hostname and comes up with the
last alias, ie "foo", !=localhost, and it drops the connection?

I'm not sure if this is a bug in SWAT or xinetd, or if the created /etc/hosts
file is munged...


Comment 6 Bill Nottingham 2000-10-16 16:51:53 UTC
*** Bug 18574 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.