Bug 178397 - abiword won't build under current devel/mock
abiword won't build under current devel/mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 23:53 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 12:23:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-19 23:53:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Abiword doesn't seem to build under current devel/mock... 

The problem appears to be missing headers in the poppler-devel package. 
The 0.4.4 version of that package has the needed headers, but the 0.5.0 version thats in devel now appears to not have them. A bug may need to be filed against that package. 

From the mock build.log: 

mkdir .libs
 g++ -DPACKAGE_NAME=\"abiword-plugins\" -DPACKAGE_TARNAME=\"abiword-plugins\" -DPACKAGE_VERSION=\"2.4.2\" "-DPACKAGE_STRING=\"abiword-plugins 2.4.2\"" -DPACKAGE_BUGREPORT=\"http://bugzilla.abisource.com/\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1
-DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STRINGS_H=1 -DPACKAGE=\"abiword\" -DVERSION=\"2.4.2\" -DHAVE_DLFCN_H=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBBZ2=1 -DTIME_WITH_SYS_TIME=1 -I. -I. -DNDEBUG -I../../../../../abi/src/af/util/xp -I../../../../../abi/src/af/util/unix -I../../../../../abi/src/af/xap/xp -I../../../../../abi/src/af/ev/xp -I../../../../../abi/src/af/gr/xp -I../../../../../abi/src/text/fmt/xp -I../../../../../abi/src/text/ptbl/xp -I../../../../../abi/src/wp/impexp/xp -I../../../../../abi/src/wp/ap/xp -I../../../../../abi/src/other/spell/xp -I../../../../../abi/src/other/fribidi/xp -I../../../../../abi/src/other/ttftool/unix -I../../../../../abi/src/af/xap/unix -I../../../../../abi/src/af/ev/unix -I../../../../../abi/src/af/gr/unix -I../../../../../abi/src/wp/ap/unix -DABI_PLUGIN_VERSION=\"2.4.2\" -DABI_PLUGIN_MAJOR=2 -DABI_PLUGIN_MINOR=4 -DABI_PLUGIN_MICRO=2 -DABI_PLUGIN_SOURCE=1 -I/usr/include/freetype2 -I/usr/include/fribidi -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/libglade-2.0 -I/usr/include/libxml2 -I/usr/include/poppler -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -MT ie_imp_PDF.lo -MD -MP -MF .deps/ie_imp_PDF.Tpo -c ie_imp_PDF.cpp
 -fPIC -DPIC -o .libs/ie_imp_PDF.o
ie_imp_PDF.cpp:31:26: error: GlobalParams.h: No such file or directory
ie_imp_PDF.cpp:32:20: error: Object.h: No such file or directory
ie_imp_PDF.cpp:33:20: error: Stream.h: No such file or directory
ie_imp_PDF.cpp:34:19: error: Array.h: No such file or directory
ie_imp_PDF.cpp:35:18: error: Dict.h: No such file or directory
ie_imp_PDF.cpp:36:18: error: XRef.h: No such file or directory
ie_imp_PDF.cpp:37:21: error: Catalog.h: No such file or directory
ie_imp_PDF.cpp:38:18: error: Page.h: No such file or directory
ie_imp_PDF.cpp:39:20: error: PDFDoc.h: No such file or directory
ie_imp_PDF.cpp:40:27: error: TextOutputDev.h: No such file or directory
ie_imp_PDF.cpp:41:23: error: CharTypes.h: No such file or directory
ie_imp_PDF.cpp:42:24: error: UnicodeMap.h: No such file or directory
ie_imp_PDF.cpp:43:19: error: Error.h: No such file or directory
ie_imp_PDF.cpp: In member function 'virtual UT_Error IE_Imp_PDF::importFile(const char*)':
ie_imp_PDF.cpp:62: error: 'GooString' was not declared in this scope
ie_imp_PDF.cpp:62: error: 'fileName' was not declared in this scope
ie_imp_PDF.cpp:62: error: expected type-specifier before 'GooString'
ie_imp_PDF.cpp:62: error: expected `;' before 'GooString'
ie_imp_PDF.cpp:64: error: 'PDFDoc' was not declared in this scope
ie_imp_PDF.cpp:64: error: 'doc' was not declared in this scope
ie_imp_PDF.cpp:64: error: expected type-specifier before 'PDFDoc'
ie_imp_PDF.cpp:64: error: expected `;' before 'PDFDoc'
ie_imp_PDF.cpp:66: error: 'globalParams' was not declared in this scope
ie_imp_PDF.cpp:66: error: expected type-specifier before 'GlobalParams'
ie_imp_PDF.cpp:66: error: expected `;' before 'GlobalParams'
ie_imp_PDF.cpp:69: error: 'gFalse' was not declared in this scope
ie_imp_PDF.cpp:70: error: 'gTrue' was not declared in this scope
ie_imp_PDF.cpp:77: error: 'TextOutputDev' was not declared in this scope
ie_imp_PDF.cpp:77: error: 'textOut' was not declared in this scope
ie_imp_PDF.cpp:77: error: expected type-specifier before 'TextOutputDev'
ie_imp_PDF.cpp:77: error: expected `;' before 'TextOutputDev'
ie_imp_PDF.cpp:79: error: type '<type error>' argument given to 'delete', expected pointer
ie_imp_PDF.cpp:87: error: type '<type error>' argument given to 'delete', expected pointer
ie_imp_PDF.cpp:89: error: type '<type error>' argument given to 'delete', expected pointer
make[4]: *** [ie_imp_PDF.lo] Error 1
make[4]: Leaving directory `/builddir/build/BUILD/abiword-2.4.2/abiword-plugins/wp/impexp/pdf/xp'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/abiword-2.4.2/abiword-plugins/wp/impexp/pdf'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/abiword-2.4.2/abiword-plugins/wp/impexp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/abiword-2.4.2/abiword-plugins/wp'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.7367 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.7367 (%build)

Happy to provide more information. 

Version-Release number of selected component (if applicable):
abiword-2_4_2-3_fc5

How reproducible:
Always

Steps to Reproduce:
1. Try and build abiword against the poppler-devel 0.5.0 package
2. It fails to compile due to missing headers. 
No abiword package. ;( 
  

Actual Results:  No abiword package. ;( 

Expected Results:  It should have compiled. 

Additional info:
Comment 1 Marc Maurer 2006-01-20 04:41:19 EST
Yep, the PDF plugin requires the old xpdf headers to be installed. I'll disable
the plugin for now, and hope to rewrite it using the new API (if that API is
suitable).
Comment 2 Marc Maurer 2006-02-05 12:23:29 EST
Disabled in rawhide

Note You need to log in before you can comment on or make changes to this bug.