Bug 178405 - yum (and rpm) fails to communicate properly with MS proxy
yum (and rpm) fails to communicate properly with MS proxy
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-20 03:07 EST by Mark Polo
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 17:07:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Polo 2006-01-20 03:07:50 EST
Description of problem:
Until about mid-way through the lifespan of FC3, I was able to use yum with the
company proxy with no problems at all. Since then, it refuses to communicate
properly with the proxy (which is, I believe, MS IIS with Websense). I am
currently using apt to get updates, as it communicates correctly with the proxy.
I have a correctly configured http_proxy environment variable, and an identical
HTTP_PROXY environment variable. I have also tried over ftp mirrors, with no
luck (same proxy). I have further attempted through the yum.conf method. None of
these has proved successful. Yum fails very quickly, so I have the impression
that it's not even trying on the proxy. I am using a particular mirror and not
the mirror list (I have verified that I can contact the mirror in the browser,
and that the URL is correct.) The environment variable is definitely correct,
because wget "just works".

Note that rpm also refuses to communicate with the proxy, so it could well be a
problem with the python libraries themselves. Using python-2.4.1-2. The problem
is becoming exacerbated as most of the repositories are deciding to remove apt
support since apt doesn't work adequately on 64bit and 98% of people use yum
successfully.

Error message:
$ sudo yum update
Password:
Setting up Update Process
Setting up repositories
Cannot open/read repomd.xml file for repository: updates-released
failure: repodata/repomd.xml from updates-released: [Errno 256] No more mirrors
to try.
Error: failure: repodata/repomd.xml from updates-released: [Errno 256] No more
mirrors to try.

$ echo $http_proxy
http://DOMAIN\USERNAME:password@172.16.110.12:80/

(In yum.conf, I have tried with both \ and \\. To set it in the shell, I use \\,
obviously.)

Version-Release number of selected component (if applicable):
yum-2.4.1-1.fc4


How reproducible:


Steps to Reproduce:
1. Set up a network using MS IIS and Websense as a proxy.
2. Try to configure yum hundreds of times without luck
3. Despair as you fail to receive updates
  
Actual results:
Setting up Update Process
Setting up repositories
Cannot open/read repomd.xml file for repository: updates-released
failure: repodata/repomd.xml from updates-released: [Errno 256] No more mirrors
to try.
Error: failure: repodata/repomd.xml from updates-released: [Errno 256] No more
mirrors to try.


Expected results:
An updated system.

Additional info:
All requests to access the Internet need to go through the proxy. Essentially
the only protocols that will reach the outside are http:// https:// and ftp://,
all going through a proxy on port 80. DNS information comes from the proxy
itself (local network DNS only provides local addresses).
Comment 1 Jeremy Katz 2006-04-19 16:35:23 EDT
Does this work better with
http://people.redhat.com/~katzj/yum-2.6.0-3.noarch.rpm on FC5?
Comment 2 Mark Polo 2006-11-17 06:55:09 EST
The solution seems to be to use ntlmaps as a local proxy to communicate with the
M$ proxy. I reported this upstream to yum and it got added to their FAQ. Maybe
ntlmaps could be packaged for extras? http://ntlmaps.sourceforge.net
Comment 3 Mark Polo 2006-11-17 15:47:25 EST
I can't check with FC5 anymore, as I am in FC6 already. My solution is in the
previous comment.

Note You need to log in before you can comment on or make changes to this bug.