Bug 178459 - Eclipse hangs on startup and cannot open previously open files
Summary: Eclipse hangs on startup and cannot open previously open files
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-20 20:08 UTC by Igor Foox
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 16:23:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace (9.49 KB, text/plain)
2006-01-20 20:08 UTC, Igor Foox
no flags Details

Description Igor Foox 2006-01-20 20:08:26 UTC
Description of problem:
A completely bizzare bug. Opening up eclipse it hung for a few minutes, taking
the whole machine with it so that mouse movement was very choppy. After a few
minutes it subsided and I started actually seeing a progress bar. After that
eclipse opened up and I had a message from the latest eclipse-bugzilla, the
message was the same that we were getting with GCC4.1 (when it tries to refresh
the repository metadata). Then one of the Java files that was previously opened
could not be opened with the following error message displayed *inside* that
editor's tab:
"
Unable to create this part due to an internal error. Reason for the failure: The
editor class could not be instantiate. This usually indicates that the editor's
class name was mistyped in plugin.xml.
"

When clicking on the "Details" plugin I get a huge stack trace, which I am
attaching.

I'll try to reproduce this but it looks like a very weird anomaly.


Version-Release number of selected component (if applicable):
gcc-4.0.2-8.fc4.i386
eclipse-platform-3.1.1-1jpp_1fc.FC4.12.i386
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2.i386

How reproducible:
Not directly reproducible so far, but bugging just in case it comes up again.

Steps to Reproduce:

  
Actual results:


Expected results:


Additional info:

Comment 1 Igor Foox 2006-01-20 20:08:27 UTC
Created attachment 123505 [details]
stack trace

Comment 2 Andrew Overholt 2006-02-07 17:02:40 UTC
Should we leave this open?  You mentioned it's difficult to reproduce ...

Comment 3 Igor Foox 2006-02-07 18:19:12 UTC
We can close it, I just filed it in case it ever comes up which it seems it won't.

Comment 4 Andrew Overholt 2006-02-08 16:23:36 UTC
(In reply to comment #3)
> We can close it, I just filed it in case it ever comes up which it seems it won't.

Okay, thanks.


Note You need to log in before you can comment on or make changes to this bug.