Bug 17847 - PATCH: tcp_wrappers '*' and '?' matching for hosts
Summary: PATCH: tcp_wrappers '*' and '?' matching for hosts
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 06:07 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 14:11:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add '*' and '?' wildcard hostname matching to hosts.{allow,deny} (3.25 KB, patch)
2000-09-26 06:08 UTC, Pekka Savola
no flags Details | Diff
case-insensitivity patch (674 bytes, patch)
2002-05-20 14:10 UTC, Pekka Savola
no flags Details | Diff
update to ipv6 parts by the author of the original patch. (1.82 KB, patch)
2002-05-20 14:11 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2000-09-26 06:07:46 UTC
Attached is a patch to make tcp_wrappers allow '*' and '?' wildcards in
hostname
matching.  This can be quite useful especially in circumstances where
subdomains haven't been named in a clever way e.g.

123.124.125.156-isdnNewYork.someisp.com

Now you could just allow *NewYork.someisp.com.

I hope this will be considered.

Comment 1 Pekka Savola 2000-09-26 06:08:46 UTC
Created attachment 3565 [details]
add '*' and '?' wildcard hostname matching to hosts.{allow,deny}

Comment 2 Pekka Savola 2000-11-02 18:36:04 UTC
Note about the patch:  that ssh was not GPL'd, it was just a generic free license.

Comment 3 Jeff Johnson 2000-12-30 22:52:22 UTC
FIxed (patch added) in tcp_wrappers-7.6-17.

Comment 4 Rudolph T Maceyko 2002-05-14 19:00:09 UTC
This patch was a good idea, but the match is done case-sensitively.

In the original SSH, the hostnames had been converted to lowercase before any
pattern matching was done.

I suggest that match_pattern_ylo also be modified to match regardless of case,
since TCP wrappers does its pattern matches without regard to case.

Comment 5 Rudolph T Maceyko 2002-05-14 19:00:10 UTC
This patch was a good idea, but the match is done case-sensitively.

In the original SSH, the hostnames had been converted to lowercase before any
pattern matching was done.

I suggest that match_pattern_ylo also be modified to match regardless of case,
since TCP wrappers does its pattern matches without regard to case.

Comment 6 Pekka Savola 2002-05-20 14:09:29 UTC
Very good idea, I didn't notice this.

I'll also attach, in the same run, an update to IPv6 parts of tcp_wrappers.

src.rpm is available at http://www.netcore.fi/pekkas/linux/ipv6/

Comment 7 Pekka Savola 2002-05-20 14:10:27 UTC
Created attachment 58007 [details]
case-insensitivity patch

Comment 8 Pekka Savola 2002-05-20 14:11:25 UTC
Created attachment 58008 [details]
update to ipv6 parts by the author of the original patch.

Comment 9 Florian La Roche 2002-06-11 20:36:23 UTC
Fixed in 7.6-22 or higher.

Thanks,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.