Bug 178492 - Had to enter kernel parameters to get installer to work
Had to enter kernel parameters to get installer to work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-20 17:52 EST by Rodd Clarkson
Modified: 2013-07-02 22:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: fc5t3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 05:23:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for 2.6.15-1.1871_FC5, sata bio, atapi_enabled=1 (51.58 KB, text/plain)
2006-01-24 13:13 EST, Benjamin Kosnik
no flags Details

  None (edit)
Description Rodd Clarkson 2006-01-20 17:52:12 EST
Description of problem:

I've just successfully installed FC5t2 on a Dell Inspiron 9300.  It uses a sata
driver for the HDD and DVD+-RW.

While previous installers have just worked, with this installer I had to pass
'linux hdc=noprobe' to get the install to find the DVD drive and then had to
tell it to install the libata(???) driver.  In the past this driver has just
been installed and I'm concerned that the average user wouldn't even know to do
this if they got this far (having had to pass kernel paramaters as well).

Without this 'interference' the installer gets to a point (still in text mode)
and then just stops.  A look at ALT-F3 shows that it can't find the cd-rom
(exact message not know, but I could find out if you want me to).

What more do you need to know to resolve this?
Comment 1 Benjamin Kosnik 2006-01-23 23:42:53 EST
Confirmed, but different all sata system.

Intel 875 set to serial ata only, pass atapi_enabled=1 hdc=noprobe hda=noprobe.
With this, sata dvd works.

If I set bios to enhanced, none of the boot options are necessary. 

However, this is a change from FC4. 

Comment 2 Benjamin Kosnik 2006-01-24 13:08:05 EST
With this morning's update, ie:

%uname -a
Linux belmont.artheist.org 2.6.15-1.1871_FC5 #1 Mon Jan 23 15:53:52 EST 2006
i686 i686 i386 GNU/Linux

behavior changed yet again.... this is ICH5 system, all sata. Have ICH5 with two
drives, one sata dvd, one seagate disk. Then, on the sata_sil connection, have
external ibm sata drive.

First boot, with: atapi_enabled=1 hdc=noprobe hda=noprobe. 
With this in, and sata-only bios config, then what happens is that only the
sata_sil comes up. Both the internal drive and the internal dvd are not found
(ie hda hdc). 

If I reboot with just: atapi_enabled=1
Then I have IDE hard drive and dvd, to wit:

[root@belmont ~]# hdparm -i /dev/hda

/dev/hda:

 Model=ST3200822AS, FwRev=3.01, SerialNo=3LJ175HD
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=268435455
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2:  ATA/ATAPI-1 ATA/ATAPI-2
ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6

 * signifies the current active mode

[root@belmont ~]# hdparm -i /dev/hdc

/dev/hdc:

 Model=PLEXTOR DVDR PX-716A, FwRev=1.09, SerialNo=126089
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2
 AdvancedPM=no
 Drive conforms to: Unspecified:  ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6

 * signifies the current active mode

This is a significant regression from FC4 with: 2.6.15-1.2003_FC4
Comment 3 Benjamin Kosnik 2006-01-24 13:10:19 EST
In addition, /dev/hdc information from hdparm is incorrect, it is not finding
the correct buffer size on the dvd.

Comment 4 Benjamin Kosnik 2006-01-24 13:13:43 EST
Created attachment 123622 [details]
dmesg for 2.6.15-1.1871_FC5, sata bio, atapi_enabled=1
Comment 5 Rahul Sundaram 2006-02-20 05:44:29 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 6 Rodd Clarkson 2006-02-20 05:57:45 EST
Ooops!  I should have mentioned that this is still a problem with current
rawhide kernels.

I'm going to reopen it and move it to rawhide.
Comment 7 Dave Jones 2006-03-08 17:14:58 EST
Still a problem ?
Comment 8 Rodd Clarkson 2006-03-09 05:05:59 EST
Nope, the installer worked fine for me (at least I didn't have to pass anything
to get it to work).

However, I have to pass hdc=noprobe to get my DVD/CD RW to work as scsi.  Should
I bugzilla this?
Comment 9 Rahul Sundaram 2006-03-09 05:09:41 EST
(In reply to comment #8)
> Nope, the installer worked fine for me (at least I didn't have to pass anything
> to get it to work).

So can you confirm that we can close this bug report?

> 
> However, I have to pass hdc=noprobe to get my DVD/CD RW to work as scsi.  Should
> I bugzilla this?

Yes. please file another bug report. 

Comment 10 Rodd Clarkson 2006-03-09 05:23:04 EST
Yes I can confirm and will close the bug.

I'll file the other issue seperately.

Note You need to log in before you can comment on or make changes to this bug.