Bug 178511 - Xinerama doesn't work
Xinerama doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-20 21:47 EST by Hugh Caley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 06:49:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf, modified to use radeon driver as requested (3.18 KB, text/plain)
2006-01-27 15:51 EST, Hugh Caley
no flags Details
Xorg log file, after changing Videocard drivers to radeon (44.84 KB, text/plain)
2006-01-27 15:52 EST, Hugh Caley
no flags Details

  None (edit)
Description Hugh Caley 2006-01-20 21:47:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Xinerama doesn't seem to work, at least with my Radeon 9200 SE card.  "Spanning Desktops" is chosen in system-config-display, and seems to be on according to Xorg.0.log, but the desktops are separate.

I am using the two outputs of the ATI card.  This worked properly with FC4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open system-config-display
2. choose spanning desktops
3. restart X or reboot
  

Actual Results:  Desktops are mirrored

Expected Results:  Desktop should span both displays

Additional info:

from Xorg.0.log:

(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Multihead layout"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Videocard0"
(**) |-->Screen "Screen1" (1)
(**) |   |-->Monitor "Monitor1"
(**) |   |-->Device "Videocard1"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Option "Xinerama" "on"
(**) Xinerama: enabled

...

(II) ATI:  Candidate "Device" section "Videocard1".
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset ATI Radeon 9200SE 5964 (AGP) found
(II) resource ranges after probing:

...

(II) VESA(0): VBESetVBEMode failed...Tried again without customized values.
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Backing store disabled
(**) Option "dpms"
(**) VESA(0): DPMS enabled
(==) RandR enabled
(II) Setting vga for screen 0.
(WW) Not including screen "Screen0" in origins calculation.

From xorg.conf:

Section "ServerLayout"
        Identifier     "Multihead layout"
        Screen      0  "Screen0" LeftOf "Screen1"
        Screen      1  "Screen1" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option      "Xinerama" "on"
        Option      "Clone" "off"
EndSection
Comment 1 Mike A. Harris 2006-01-24 18:11:51 EST
VESA VBE does not support multihead, so it is not possible to access both heads
on one card using the "vesa" driver.  Please reconfigure xorg.conf to use the
"radeon" driver, and provide a status update.  If the problem still exists with
the "radeon" driver, please attach your X server log file and config file as
individual uncompressed file attachments using the file attachment link below.
Please do not paste them into the comment field.

Thanks in advance.
Comment 2 Hugh Caley 2006-01-27 15:51:17 EST
Created attachment 123795 [details]
xorg.conf, modified to use radeon driver as requested
Comment 3 Hugh Caley 2006-01-27 15:52:10 EST
Created attachment 123796 [details]
Xorg log file, after changing Videocard drivers to radeon
Comment 4 Hugh Caley 2006-01-27 15:53:27 EST
system-config-display configures Videocard0 with "vesa", and Videocard1 with
"ati".  Changing both to "radeon" made no difference".  Requested files now
attached.
Comment 5 Mike A. Harris 2006-01-27 18:44:32 EST
(In reply to comment #4)
> system-config-display configures Videocard0 with "vesa", and Videocard1 with
> "ati".

Yep, that's due to missing driver metadata files in test2.  Should be fixed
in rawhide soon with a driver package update though.  Probably sometime next
week.


> Changing both to "radeon" made no difference".  Requested files now
> attached.

BusID needs to be present in both device sections generally for proper
operation.  This may also be a system-config-display bug perhaps.  Can
you add BusID to the other section and test?



Comment 6 Hugh Caley 2006-01-27 18:54:21 EST
BusID would be the same for both displays, correct?  It didn't make any
difference to add it to the other display.
Comment 7 Mike A. Harris 2006-01-31 12:41:09 EST
(In reply to comment #6)
> BusID would be the same for both displays, correct?  It didn't make any
> difference to add it to the other display.

Yes, BusID should be the same for each head in a single card.  It is
mandatory to supply it in the config file, however our config tool may
be broken in this regard (it has been in the past).

Does Option "noaccel" help at all?
Comment 8 Hugh Caley 2006-01-31 15:16:36 EST
I added Option "noaccel" to both Videocards.  It didn't make a difference.
Comment 9 Mike A. Harris 2006-02-21 06:49:05 EST
Fedora Core 5 test3 has been released.  Please update to the latest test
release and if the problem is still present, please file a bug report in
X.Org bugzilla at http://bugs.freedesktop.org in the "xorg" component.

Be sure to attach your current X server log, config file and all details
directly to the X.Org bugzilla so that the upstream driver maintainers
have as many details as possible in order to the issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "RAWHIDE"


Note You need to log in before you can comment on or make changes to this bug.