Bug 178530 - Program hangs when accessing the openGL library
Program hangs when accessing the openGL library
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 08:33 EST by Karl Meyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-22 02:07:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Meyer 2006-01-21 08:33:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I am using the NVIDIA-Linux-x86-1.0-8178-pkg1 with all the patches from the website I can find. The reason you are getting the first shot at this is because the same driver works with 2.6.15-1.1826.2.10_FC5smp but fails with any kernel after that (I've tried them all) 
X loads and runs fine, but when I fire off the Never Winter Nights program I get the splash screen and then it will lock up when it tries to load the menu screen. This is a hard lock, I can't do anything, CTL-ALT-F(1-6) does nothing letting it sit does nothing and my only option is to hit the reset on the computer. I looked at the logs and could find nothing in them indicating a problem. 
I've downlosded an older version of the nVidia driver which I will try today and play with things that way. But something changed after the 1826 kernel to break this so you get the first crack at finding the cause. (Lucky you) 
If the older driver works I will let you know. But there is a fair amount of nVidia cards out there and this is nasty enough to warrant some investigation. I wouldn't be as concerned if it didn't just lock the system up. 
This game works a lot better on linux than it ever did on that other OS.
Thanks
Karl

Version-Release number of selected component (if applicable):
every kernel after 2.6.15-1.1826.2.10_FC5smp

How reproducible:
Always

Steps to Reproduce:
1.Run NWN with the nVidia driver (8178) on a recent kernel.
2.
3.
  

Actual Results:  System locks up hard. Reset is the only option.

Expected Results:  Hours of wasted time playing the game. Mad wife, the usual stuff. 

Additional info:

I couldn't find any info anywhere it just locks up and that is it.
Comment 1 Dave Jones 2006-01-22 02:07:33 EST
rawhide changes on a daily basis, out of tree drivers tend to lag behind and not
adapt to changes.

I suggest taking this to nvidia forums.
Comment 2 Karl Meyer 2006-01-26 06:21:04 EST
Being a world class procrastinator I have not contacted the nVidia people yet.
However the most recent kernel 2.6.15-1.1872_FC5smp is working again. So it was
something that broke on the kernels between 1826 and 1872. Just an FYI I know
you get a lot of reports and hopefully this will give you a bit more insight
into what caused this one. 
It works now so I am happy and once again on the most recent kernel release. 
Thanks
Karl

Note You need to log in before you can comment on or make changes to this bug.