Bug 178557 - nForce3 ethernet not recognized (forcedeth)
nForce3 ethernet not recognized (forcedeth)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 12:17 EST by John Reiser
Modified: 2014-03-16 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 13:03:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-01-21 12:17:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
lspci says that the builtin ethernet on nVidia nForce3 chipset is a Bridge.  It should be a Communications device.

Version-Release number of selected component (if applicable):
pciutils-2.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. /sbin/lspci
2.
3.
  

Actual Results:  $ /sbin/lspci
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
        ^^^^^^^                    ^^^^^^^^^^^^^

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:09.0 IDE interface: nVidia Corporation CK8S Serial ATA Controller (v2.5) (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
[jreiser@fc5t2-amd64 ~]$ rpm -qf /sbin/lspci
pciutils-2.2.1-1
[jreiser@fc5t2-amd64 ~]$ /sbin/lspci -n
00:00.0 0600: 10de:00e1 (rev a1)
00:01.0 0601: 10de:00e0 (rev a2)
00:01.1 0c05: 10de:00e4 (rev a1)
00:02.0 0c03: 10de:00e7 (rev a1)
00:02.1 0c03: 10de:00e7 (rev a1)
00:02.2 0c03: 10de:00e8 (rev a2)
00:05.0 0680: 10de:00df (rev a2)
^^^^^^^^^^^^^^^^^^^^^^^

00:06.0 0401: 10de:00ea (rev a1)
00:08.0 0101: 10de:00e5 (rev a2)
00:09.0 0101: 10de:00ee (rev a2)
00:0b.0 0604: 10de:00e2 (rev a2)
00:0e.0 0604: 10de:00ed (rev a2)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:00.0 0300: 1002:5960 (rev 01)
01:00.1 0380: 1002:5940 (rev 01)
$ 


Expected Results:  00:05.0 Communication device: nVidia Corporation CK8S Ethernet Controller (rev a2)
        ^^^^^^^^^^^^^

Additional info:

This seems to be related to the problem that anaconda-10.91.6 cannot install from boot.iso or rescue.iso on this machine, even though it does load the forcedeth driver.  See Bug #156688, which claims to have been fixed over a half year ago in an update to RHEL4.

/etc/sysconfig/hwconf gets it right:
class: OTHER
bus: PCI
detached: 0
driver: forcedeth
desc: "nVidia Corporation CK8S Ethernet Controller"
vendorId: 10de
deviceId: 00df
subVendorId: 1462
subDeviceId: 0250
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  5
pcifn:  0
Comment 1 John Reiser 2006-01-21 15:32:05 EST
pciutils-2.1.99.test8-3.1 on RHEL4u2 (kernel-2.6.9-22) says
$ /sbin/lspci
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Ethernet controller: nVidia Corporation CK8S Ethernet Controller (rev a2)
^^^^^^^^^^^^^^^^^^^^^^^^^^^

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97
Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5)
(rev a2)
00:09.0 IDE interface: nVidia Corporation CK8S Serial ATA Controller (v2.5) (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO]
(rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5940 (rev 01)
$ /sbin/lspci -n
00:00.0 Class 0600: 10de:00e1 (rev a1)
00:01.0 Class 0601: 10de:00e0 (rev a2)
00:01.1 Class 0c05: 10de:00e4 (rev a1)
00:02.0 Class 0c03: 10de:00e7 (rev a1)
00:02.1 Class 0c03: 10de:00e7 (rev a1)
00:02.2 Class 0c03: 10de:00e8 (rev a2)
00:05.0 Class 0200: 10de:00df (rev a2)
^^^^^^^^^^^^^^^^^^

00:06.0 Class 0401: 10de:00ea (rev a1)
00:08.0 Class 0101: 10de:00e5 (rev a2)
00:09.0 Class 0101: 10de:00ee (rev a2)
00:0b.0 Class 0604: 10de:00e2 (rev a2)
00:0e.0 Class 0604: 10de:00ed (rev a2)
00:18.0 Class 0600: 1022:1100
00:18.1 Class 0600: 1022:1101
00:18.2 Class 0600: 1022:1102
00:18.3 Class 0600: 1022:1103
01:00.0 Class 0300: 1002:5960 (rev 01)
01:00.1 Class 0380: 1002:5940 (rev 01)
Comment 2 Harald Hoyer 2006-01-23 07:52:06 EST
I think this is a kernel issue like bug #156688 
Comment 3 Dave Jones 2006-01-23 12:31:35 EST
the pci header claims its a bridge.  iirc in RHEL4 we made the kernel munge it
into looking like an ethernet device so that it didn't break the installer.
Post RHEL4, we fixed the installer to cope with ethernet devices with incorrect
PCI headers.

as long as forcedeth is being loaded, it should work.
Comment 4 John Reiser 2006-01-23 13:27:04 EST
The installer (anaconda-10.91.6) did not work, even though log screens show that
forcededth has been loaded.  Re-open.  The installer claims no appropriate
device for HTTP install, and offers a list of known drivers that does not
include forcedeth, or offers to let the operator use a driver disk.  I resorted
to downloading the whole DVD.  That worked, and forcedeth is automatically
recognized at boot, and ethernet works after boot.  So now three fingers
(pciutils, kernel, user) are pointing to the installer.
Comment 5 Dave Jones 2006-01-24 00:12:19 EST
if you flip to tty1, does running /sbin/ifconfig eth0 after forcedeth has loaded
show an interface ?
Comment 6 John Reiser 2006-01-24 09:47:20 EST
So far, I cannot get a shell from the installer.

boot: linux askmethod vga=791  # using x86_64 rescue .iso from FC5t2
<<get to Choose a Language; screens now are:
  <Alt><F1> Choose a Language
  <Alt><F2> same as <Alt><F1>
  <Alt><F3> many lines of INFO, including (near the bottom)
    loaded forcedeth from /modules/modules.cgz
    loaded libata from /modules/modules.cgz
    loaded sata_nv from /modules/modules.cgz
    inserted /tmp/forcededth.ko
    inserted /tmp/libata.ko
    inserted /tmp/sata_nv.ko
  <Alt><F4> debug "drivel" including (near the top)
    <7>PCI: Setting latency timer of device 0000:00:05.0 to 64
    <6>eth0: forcedeth.c: subsystem: 1462:0250 bound to 0000:00:05.0
  <Alt><F5, F6, F7, F8> same as <Alt><F4>
The F3 and F4 screens echo console typing, but there is no shell.
>>

<<select English, US English; get to Installation Method, choose HTTP>>
<<No driver found; screens are as above: no shell>>
Comment 7 John Reiser 2006-01-24 09:58:08 EST
boot: <Enter>  # using x86_64 full install DVD from FC5t2
<<get to Fedora logo screen; <Alt><F2> gives a shell:
$ ifconfig -a
eth0    Link encap: Ethernet   HWaddr <<correct info>>
        BROADCAST MULTICAST  MTU:1500 Metric:1   ## not UP
        RX packets:  <<all zero>>
        TX packets:  <<all zero>>
        collisions:0  txqueuelen: 1000
        RX bytes: <<all zero>>
        Interrupt: 201 Base address: 0xc000

lo      <<correct info>>
>>
Comment 8 John W. Linville 2006-01-24 10:55:55 EST
That would certainly seem to indicate an available interface...? 
Comment 9 Jeremy Katz 2006-01-24 11:08:54 EST
We had added a bad hack to kudzu -- it looks like there's a new PCI id that
needs the same hack applied :(
Comment 10 Bill Nottingham 2006-01-24 13:03:13 EST
Fixed in 1.2.21-1. Now if we have a nVidia device that uses forcedeth that
claims to be a bridge, we treat it as network no matter what the device id is.

Note You need to log in before you can comment on or make changes to this bug.