Bug 178560 - gnome-keyboard-properties
gnome-keyboard-properties
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 13:01 EST by Yves Bellefeuille
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yves Bellefeuille 2006-01-21 13:01:50 EST
This is about gnome-keyboard-properties; I don't whether whether gnome-applets
is the right heading under which to report this.

The keyboard layouts listed under Canada are obviously incorrect. In particular,
the layout called French Dvorak (under Canada) uses Qwerty, according to the
preview.

In Fedora 4, I used the layout called French Canadian, but can't get it to work
under Fedora 5.
Comment 1 Va Mo 2006-02-12 06:09:32 EST
There is a problem to select nested layout of keyboard for Czechia: Keyboard
Applet->Open Keyboard Preferencies->Layout->Add->Czechia->select "querty"->
press OK -> It crashes and gives following message:
--------------------------------------------------------------------------
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70000000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
--------------------------------------------------------------------------

The wanted results:

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", "grp:alts_toggle"

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us]
 model =
 options = [grp grp:alts_toggle]
 overrideSettings = true

When there is choosen only Czechia - not nested layouts like querty, querty
extended Backslah or With <\}> key - it doesn't crash and seems to work properly
- only with layout quertz.
Comment 2 Rahul Sundaram 2006-02-20 06:00:07 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Yves Bellefeuille 2006-03-04 18:50:41 EST
The problem I reported with the Canadian keyboard layouts still exists under
Fedora 5 test 3.
Comment 4 Red Hat Bugzilla 2007-02-05 14:14:59 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 Matthew Miller 2007-04-06 13:15:46 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 6 Stephen Winnall 2007-06-26 10:45:23 EDT
I get this problem with the following setup:

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "ch", "de_nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "ch", "de_nodeadkeys", ""

 layouts = [de_CH] model = microsoftinet
 overrideSettings = false
 options = []

Steve
Comment 7 Stephen Winnall 2007-06-26 10:47:00 EDT
Sorry, I should add that I had this problem under Fedora 6 and it persists under
Fedora 7.

Steve

(In reply to comment #6)
> I get this problem with the following setup:
> 
> _XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "ch", "de_nodeadkeys", ""
> _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "ch", "de_nodeadkeys", ""
> 
>  layouts = [de_CH] model = microsoftinet
>  overrideSettings = false
>  options = []
> 
> Steve

Comment 8 Ray Strode [halfline] 2007-08-14 11:53:20 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.