Bug 17858 - failure for install
failure for install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-26 10:31 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-29 12:01:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-26 10:31:55 EDT
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 2048256
fsystem: ext2
self: <fstab.GuiFstab instance at 84baab0>
msg: Invalid argument
doFormat: 0
errno: 22
device: sda7
instPath: /mnt/sysimage
mntpoint: /home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-09-26 11:01:08 EDT
Was this an install or upgrade?

Did you choose to format /home if it was a separate partition?
Comment 2 Need Real Name 2000-09-26 16:21:18 EDT
This was a complete install over an old system.

I didn't choose to install over home.  Thinking back over now, i didn't choose 
to format home.  This would have been a problem because home was in a different 
portion of the drive.  So of course it would fail.  So i'm thinking that the 
default option should have been to format home...
Comment 3 Need Real Name 2000-09-26 18:46:23 EDT
no i didn't format home.
Comment 4 Michael Fulbright 2000-09-29 12:03:57 EDT
We don't make it in by default because it is not uncommon for people to
reinstall machines and we thought it
safer to not format the data they want to keep.

Sorry this wasn't clearer.

Note You need to log in before you can comment on or make changes to this bug.