Bug 178591 - update-desktop-database relies on uninitialised memory
update-desktop-database relies on uninitialised memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 176730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 01:18 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-22 15:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-01-22 01:18:04 EST
run MALLOC_PERTURB_=134 update-desktop-database, and it segfaults.

Program received signal SIGSEGV, Segmentation fault.
0x0000003c3b98df36 in opendir () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003c3b98df36 in opendir () from /lib64/libc.so.6
#1  0x0000003a09a184d9 in g_dir_open () from /usr/lib64/libglib-2.0.so.0
#2  0x00000000004024df in process_desktop_files (
    desktop_dir=0x7979797979797979 <Address 0x7979797979797979 out of bounds>,
    prefix=0x406730 "", error=0x7fffffdfb6f0) at update-desktop-database.c:238
#3  0x0000000000402b0d in main (argc=1, argv=Variable "argv" is not available.
) at update-desktop-database.c:419
#4  0x0000003c3b91cde4 in __libc_start_main () from /lib64/libc.so.6
#5  0x0000000000402429 in _start ()
#6  0x00007fffffdfb808 in ?? ()
#7  0x0000000000000000 in ?? ()
Comment 1 Ray Strode [halfline] 2006-01-22 15:53:41 EST
Thanks, should be fixed in tomorrows rawhide.
Comment 2 Matthias Clasen 2006-02-05 00:01:31 EST
*** Bug 176730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.