Bug 178613 - ATI video driver spec file is lacking "BuildRequires: libdrm-devel"
ATI video driver spec file is lacking "BuildRequires: libdrm-devel"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 08:40 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 02:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-01-22 08:40:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.5.1

Description of problem:
Compilation of "xorg-x11-drv-ati-6.5.7.2-1.src.rpm" aborts
unless one installs "libdrm-devel". It shoud be added to
the build requirements.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.2-1

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild xorg-x11-drv-ati-6.5.7.2-1.src.rpm
  

Actual Results:  After passing the "%prep" stage successfully, the "configure" step
aborts because of missing "DRM" header files.

Expected Results:  The compilation should have completed as expected.

Additional info:

Additional installation of "libdrm-devel" allows to build the
binary "xorg-x11-drv-ati-6.5.7.2-1.i386.rpm" RPM.
Comment 1 Mike A. Harris 2006-01-27 18:45:35 EST
Thanks for the report.  I'll fix that in the next driver update.
Comment 2 Mike A. Harris 2006-02-03 02:51:59 EST
Fixed in xorg-x11-drv-ati-6.5.7.3-2

Note You need to log in before you can comment on or make changes to this bug.