Bug 178636 - rpath test failures in rpmdevtools, rawhide
rpath test failures in rpmdevtools, rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-rpmdevtools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 16:36 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-04 11:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes rpath tests on FC5 (623 bytes, patch)
2006-02-04 07:43 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2006-01-22 16:36:05 EST
The rpath tests fail currently on Rawhide:

Checking the bad programs
  checking for error 0001 in link-0                             FAIL
  checking for error 0004 in link-1                             FAIL
  checking for error 0010 in link-2                             FAIL
  checking for error 0020 in link-3                             FAIL
  checking for error 0020 in exec-0                             FAIL

Others are fine.  Enrico, could you have a look?
Comment 1 Enrico Scholz 2006-02-04 07:43:01 EST
Created attachment 124158 [details]
Fixes rpath tests on FC5

Seems to be caused by changes in bash; my 'IFS=:' caused bash 3.1 to print

| ERROR   0010	file '/fail/link-2' contains an empty rpath in []

while the test expected

| ERROR   0010: file '/fail/link-2' contains an empty rpath in []

(note the missing ':')
Comment 2 Ville Skyttä 2006-02-04 11:57:39 EST
Applied in 1.4-2, thanks!

Note You need to log in before you can comment on or make changes to this bug.