Bug 178638 - latest stable modules ieee80211+ipw2200 fail modprobe under 2.6.14-1.1656_FC4
latest stable modules ieee80211+ipw2200 fail modprobe under 2.6.14-1.1656_FC4
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 17:22 EST by Wes
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 01:28:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wes 2006-01-22 17:22:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
compiled drivers from source to get Intel 2915ABG to work:
lspci | grep 2915
04:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI Adapter (rev 05)

under 2.6.11-1.1369_FC4 the newest ieee80211 and ipw2200 modules compile, load, and work.

under 2.6.14-1.1656_FC4 modprobe of ieee80211 works but modprobe ipw2200 gives errors:

kernel: ipw2200: Unknown symbol ieee80211_wx_get_encodeext
kernel: ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
kernel: ipw2200: Unknown symbol ieee80211_wx_set_encode
kernel: ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
kernel: ipw2200: Unknown symbol ieee80211_wx_get_encode
kernel: ipw2200: disagrees about version of symbol ieee80211_txb_free
kernel: ipw2200: Unknown symbol ieee80211_txb_free
kernel: ipw2200: Unknown symbol ieee80211_wx_set_encodeext
kernel: ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
kernel: ipw2200: Unknown symbol ieee80211_wx_get_scan
kernel: ipw2200: disagrees about version of symbol ieee80211_rx
kernel: ipw2200: Unknown symbol ieee80211_rx
kernel: ipw2200: disagrees about version of symbol ieee80211_rx_mgt
kernel: ipw2200: Unknown symbol ieee80211_rx_mgt
kernel: ipw2200: disagrees about version of symbol free_ieee80211
kernel: ipw2200: Unknown symbol free_ieee80211
kernel: ipw2200: disagrees about version of symbol alloc_ieee80211
kernel: ipw2200: Unknown symbol alloc_ieee80211



Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1656_FC4, ipw2200-1.0.10, ieee80211-1.1.9

How reproducible:
Always

Steps to Reproduce:
1. install fc4
2. yum update
3. download ieee80211-1.1.9.tgz from
http://ieee80211.sourceforge.net/#downloads
remove-old
make && make install

4. download ipw2200-1.0.10.tgz from:
http://ipw2200.sourceforge.net/
remove-old

5. download firmware 2.4 from
http://ipw2200.sourceforge.net/firmware.php
extract to /lib/firmware

6. modprobe ieee80211
7. modprobe ipw2200
check dmesg for errors

Actual Results:  modprobe ipw2200 failed and errors cited above in dmesg output

Expected Results:  module ipw2200 loaded.

Additional info:

reboot back to base fc4 install and "Steps to Reproduce" works and the module is loaded.  then the card can be configured as eth1 and used.
Comment 1 Dave Jones 2006-01-24 01:28:42 EST
if you have problems in self-compiled modules, tell the people who made them.

Note You need to log in before you can comment on or make changes to this bug.