Bug 178639 - NV driver won't work at any resolution
NV driver won't work at any resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 17:42 EST by Dave Burgess
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 06:05:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is after the initial installation (34.70 KB, text/plain)
2006-01-25 18:44 EST, Dave Burgess
no flags Details
This is the xorg.conf anaconda created (2.42 KB, text/plain)
2006-01-25 18:45 EST, Dave Burgess
no flags Details
Initial files (40.00 KB, application/octet-stream)
2006-02-04 15:36 EST, Dave Burgess
no flags Details
Using Option noaccel (40.00 KB, application/octet-stream)
2006-02-04 15:37 EST, Dave Burgess
no flags Details
Using Option EXA (40.00 KB, application/octet-stream)
2006-02-04 15:39 EST, Dave Burgess
no flags Details
Digicam snap of screen (1.79 MB, image/jpeg)
2006-02-04 15:44 EST, Dave Burgess
no flags Details

  None (edit)
Description Dave Burgess 2006-01-22 17:42:37 EST
Description of problem:
 The nv driver as shipped in FC5 won't work.  My card is properly detected but
when I configure ANY resolution.  I've evem tried 640x480 and it won't work.  X
starts, my screen goes blank and that's all that happens.


Version-Release number of selected component (if applicable):


How reproducible:

Every time any and all resolutions or monitors.

Steps to Reproduce:
1. Use system-config-display to configure the display to any resolution.
2. startx
3. x server seems to start
4. Nothing appears.
5. Ctrl-backspace and text comes back but the sytem then "hangs" a reboot is 
   required.
  
Actual results:


Expected results:

I expect a nice X session to start.

Additional info:

MSI K8N-F Motherboard
GeForce 6600 GT video

Here's video card portion from the output of lspci

05:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT]
(rev a2) (prog-if 00 [VGA])
Comment 1 Mike A. Harris 2006-01-24 21:22:37 EST
Attach your X server log file and config file seperately, using the link below.
Comment 2 Dave Burgess 2006-01-25 18:44:33 EST
Created attachment 123698 [details]
This is after the initial installation
Comment 3 Dave Burgess 2006-01-25 18:45:37 EST
Created attachment 123699 [details]
This is the xorg.conf anaconda created
Comment 4 Mike A. Harris 2006-01-31 12:38:20 EST
Test the following option in the device section of your config:

    Option "noaccel"

Does this have any effect?
Comment 5 Dave Burgess 2006-02-02 17:34:52 EST
Well ... it has an effect just not a very good one.

With this option at least I get something on my display not just "blank".

However what I get is a series of vertical multicoloured bars and I can tell (if
I use my imagination) that in there is an extremely low resolution desktop
instead of my 1600x1200 one.

It almost reminds me of the Matrox issue with Core 4, seems to me that was some
sorta obscure gcc bug.  
Comment 6 Mike A. Harris 2006-02-03 07:09:48 EST
A new X server and nv driver is available now, from the version that
the report was initially filed against.  Please upgrade to the following
packages:

xorg-x11-server-1.0.1-1
xorg-x11-drv-nv-1.0.1.5-1

Once you've updated, run "system-config-display --reconfig" and then reboot
to ensure the video card is reset to power on state.  Try the new X server
and driver out, and update the report to reflect the current status, and
any notable changes.

If you still observe problems, try the "noaccel" option in the device
section again, and if that doesn't change anything, then comment out
the noaccel option and try the following:

Option "AccelMethod" "EXA"

Let us know if that works or not also.

Hope this helps.
Comment 7 Dave Burgess 2006-02-04 15:36:16 EST
Created attachment 124181 [details]
Initial files

plain.tar contains xorg.conf and the Xorg log file created when I ran
system-config-display --reconfig

BTW The new drivers did NOT help.
Comment 8 Dave Burgess 2006-02-04 15:37:32 EST
Created attachment 124182 [details]
Using Option noaccel

This tar ball contains the xorg.conf and Xorg log files created usign the
noaccel option.

Still didn't work.
Comment 9 Dave Burgess 2006-02-04 15:39:03 EST
Created attachment 124183 [details]
Using Option EXA

This tarball contains the xorg.conf and Xorg log files created using Option
"AccelMethod" "EXA"

Still doesn't work.
Comment 10 Dave Burgess 2006-02-04 15:44:26 EST
Created attachment 124184 [details]
Digicam snap of screen

This is a digital camera shot of what the screen looks like.

Sorry for the large size.
Comment 11 Mike A. Harris 2006-02-09 12:09:47 EST
When attaching log/config files, please attach them untarred so they're
viewable inside the web browser.  I've had a look at your files and I
notice the following:


No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295


That bug was recently fixed with the latest mesa and xorg-x11-server
updates on x86_64.  Please update to the current packages to see if
that problem goes away, as that may be the cause of the issue you
initially reported.

If the problem still exists with the latest updates however, you'll
need to file a bug report in X.Org bugzilla located at
http://bugs.freedesktop.org in the "xorg" component, against the open
Nvidia driver, as it will require direct investigation by the driver
maintainers at Nvidia.  They're the only ones with the hardware
documentation and knowledge of the operation of their hardware
unfortunately.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting bug update, with
X.Org bug URL for tracking if the problem remains in the latest
updates.

Thanks in advance.
Comment 12 Dave Burgess 2006-02-19 13:20:21 EST
I applied all the updates I could on Sunday Feb 19th.

I'm now running kernel 1955 and have the nv drivers version 1.0.1.5-3.1

It now works okay, however there is an obvious bug with gnome-display-properties
that I'll have to check into.

xorg.conf correctly has the resolution set to 1600x1200 but
gnome-display-properties will not allow a resolution higher than 1280x960.
Comment 13 Jacob Keller 2006-02-19 23:11:07 EST
I get the same problem, but my g-d-p only lets upto 1024x786.  It is really
annoying, because I select 1600x1200.  Is there anyway to get g-d-p to get
1600x1200?
Comment 14 Mike A. Harris 2006-02-21 06:05:45 EST
(In reply to comment #12)
> I applied all the updates I could on Sunday Feb 19th.
> 
> I'm now running kernel 1955 and have the nv drivers version 1.0.1.5-3.1
> 
> It now works okay
[SNIP]
> xorg.conf correctly has the resolution set to 1600x1200 but

Ok, thanks.  Closing bug as resolved in RAWHIDE.  Presumeably you've filed
separate bug reports for any new problems you've encountered, and they
will be tracked separately.

Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.