Bug 178646 - yumdownloader fails to start due to missing returnBestPackages library function
Summary: yumdownloader fails to start due to missing returnBestPackages library function
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-23 01:52 UTC by Henrik Nordstrom
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 10:49:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Nordstrom 2006-01-23 01:52:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
$ rpm -q yum-utils yum
yum-utils-0.3.1-1.fc5
yum-2.5.1-2

$ yumdownloader 
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 27, in ?
    from yum.packages import parsePackages, returnBestPackages
ImportError: cannot import name returnBestPackages


Actual Results:  Program failed to load

Expected Results:  Should give a quick usage summary, as no further instructions was given to the command.

Additional info:

Running FC5 TEST2.

Comment 1 Tom Tromey 2006-01-31 17:31:55 UTC
This looks like a dup of bug #175335


Comment 2 Tim Lauridsen 2007-02-06 10:49:35 UTC
This bug should not exist any more, so i will close it.


Note You need to log in before you can comment on or make changes to this bug.