Bug 178648 - Word Completion in the editor not working
Word Completion in the editor not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 21:42 EST by Tony Tsui
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 11:49:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 26166 None None None Never

  None (edit)
Description Tony Tsui 2006-01-22 21:42:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.5.1

Description of problem:
Doing Word Completion, via the shortcut Alt+/, in the text editor results in a error dialog appearing with the following message:

"Word Completion" did not complete normally. Please see the log for more information.

Reason:
java.lang.NullPointerException

Clicking on the Details button only shows "java.lang.NullPointerException" in the text box.

Doing Word Completion via the Edit menu doesn't do anything, i.e. word is not completed, although there is no error dialog.

This happens in the editor for Java, C and Python files.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_15fc

How reproducible:
Always

Steps to Reproduce:
1. Type a few characters of an existing word
2. Press Alt+/ OR Go to Edit->Word Completion

Actual Results:  Alt+/ produces and error dialog.
Edit->Word Completion doesn't do anything

Expected Results:  The word is completed.

Additional info:
Comment 1 Andrew Overholt 2006-02-03 16:33:34 EST
Pertinent stack trace:

java.lang.NullPointerException
   at
org.eclipse.ui.internal.texteditor.HippieCompletionEngine.getCompletionsBackwards
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at
org.eclipse.ui.texteditor.HippieCompleteAction.createSuggestionsFromOpenDocument
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.HippieCompleteAction.getSuggestions
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.HippieCompleteAction.updateState
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.HippieCompleteAction.run
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.jface.action.Action.runWithEvent (org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.ui.commands.ActionHandler.execute
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.handlers.LegacyHandlerWrapper.execute
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.core.commands.Command.execute
(org.eclipse.core.commands_3.1.0.jar.so)
   at org.eclipse.core.commands.ParameterizedCommand.execute
(org.eclipse.core.commands_3.1.0.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindings
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEvent
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.swt.widgets.EventTable.sendEvent
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.filterEvent
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Control.traverse
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Control.translateMnemonic
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Composite.translateMnemonic
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Control.translateMnemonic
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Control.gtk_key_press_event
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Composite.gtk_key_press_event
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Widget.windowProc
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.windowProc
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
Comment 2 Andrew Overholt 2006-02-07 16:49:26 EST
This is a class library issue.  I'll add a reference to the upstream bug.
Comment 3 Tom Tromey 2006-02-13 17:58:34 EST
I checked in the regex fix to the gcc 4.1 branch.
Comment 4 Andrew Overholt 2006-02-20 11:49:37 EST
(In reply to comment #3)
> I checked in the regex fix to the gcc 4.1 branch.

Thanks.  This works for me now with gcc-4.1.0-0.27.


Note You need to log in before you can comment on or make changes to this bug.