Bug 178689 - avahi-daemon logs wrong timezone to /var/log/messages
avahi-daemon logs wrong timezone to /var/log/messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 10:31 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 09:46:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-01-23 10:31:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Not sure this is an avahi issue, but 'avahi-daemon' entries in /var/log/messages have date/times NOT adjusted for local timezone:

Jan 23 07:28:01 localhost kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 100 Mbps Full Duplex
Jan 23 07:28:01 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Jan 23 07:28:02 localhost dhclient: DHCPOFFER from 192.168.1.1
Jan 23 07:28:02 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Jan 23 07:28:02 localhost dhclient: DHCPACK from 192.168.1.1
Jan 23 15:28:02 localhost avahi-daemon[2646]: New relevant interface eth0.IPv4 for mDNS.
Jan 23 15:28:02 localhost avahi-daemon[2646]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.101.
Jan 23 15:28:02 localhost avahi-daemon[2646]: IP_ADD_MEMBERSHIP failed: Address already in use
Jan 23 15:28:02 localhost avahi-daemon[2646]: Registering new address record for 192.168.1.101 on eth0.
Jan 23 07:28:02 localhost NET[4386]: /sbin/dhclient-script : updated /etc/resolv.conf
Jan 23 07:28:02 localhost dhclient: bound to 192.168.1.101 -- renewal in 36730 seconds.


Version-Release number of selected component (if applicable):
avahi-0.6.4-3

How reproducible:
Always

Steps to Reproduce:
1. boot
2.
3.
  

Additional info:
Comment 1 Jason Vas Dias 2006-01-23 15:54:48 EST
Yes, this is because /etc/localtime does not exist in the avahi chroot directory,
/etc/avahi .  
I guess the initscript should be creating this file if it does not exist - 
this is now fixed with avahi-0.6.4-4 .
Comment 2 Tom London 2006-01-25 09:46:21 EST
Works for me in avahi-0.6.4-4

Closing.

Note You need to log in before you can comment on or make changes to this bug.