Bug 178715 - total download transaction summary ignores already downloaded rpms
total download transaction summary ignores already downloaded rpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 13:44 EST by David Timms
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-01-23 13:44:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
The yum download process statistics don't take into account that some packages might alread be downloaded (eg from a fast private mirror, or another machine that is getting rsync from etc). This gives an impression that it might have to do a large download, when it may even have all the files downloaded through some other method (eg local/private mirroring/downloading).

Version-Release number of selected component (if applicable):
yum-2.5.1-1

How reproducible:
Always

Steps to Reproduce:
1. yum update
2. kill the update half way though the numner of packages it needs to download
3. yum update

Actual Results:  Initial summary showed eg 448M, 286 packages.
Second summary showed the same.

Expected Results:  Download size and count of already downloaded packages should reduce the above values.

Additional info:

Summary could be like:
Transaction Summary
=== (umm need to fit nicely in w=80)
Install    11 Packages(s)  (25M).  (Download of  6 packages (11M) needed.
Update    275 Packages(s) (420M).  (Download of 85 packages (63M) needed.
etc
Do download (y) or (n)  [(d) download only - new item!]
y or d
Downloading Packages.
===
Also check disk just before each download to avoid downloading / overwriting files that appear between start of yum download and starting a particular file. Currently, an ftp or rsync that happens between the beginning of yum  downloading packages and the yum download means that a rpm may be erased if yum gets to that same package. The file is erased and redownloaded from the yum mirror (at slower speed and not a free download).
Comment 1 Brian 2006-04-19 09:33:02 EDT
When attempting to run yum from the cache (yum -C update), errors such as this
happen:

logwatch - 7.2.1-1.fc5.noarch: Caching enabled but no local cache of
//var/cache/yum/updates-released/packages/logwatch-7.2.1-1.fc5.noarch.rpm from
updates-released

The file does exist, but notice the // at the begining of the file path.  Could
this be the reason yum fails to detect packages that are already downloaded?
Comment 2 Seth Vidal 2006-04-19 09:36:20 EDT
no, it's not.

multiple slashes are allowed by the posix specification.
Comment 3 Jeremy Katz 2006-04-19 16:36:04 EDT
The packages are checked for validity at the download step and if they're
corrupted/not complete, then they could be downloaded.  Think of it as the
amount that may need to be downloaded.

Note You need to log in before you can comment on or make changes to this bug.